summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-08-17 21:37:14 -0400
committerGuillaume Horel2019-08-17 21:37:14 -0400
commitd4c59197df576ba53f32ceced375d0e02b8eb28b (patch)
tree7d62f1fc1721f23c6fc98685bf5cc9c5b59ad6e1
downloadaur-d4c59197df576ba53f32ceced375d0e02b8eb28b.tar.gz
initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD27
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e3330e238a4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-fontpens
+ pkgdesc = A collection of classes implementing the pen protocol for manipulating glyphs.
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = https://pypi.org/project/fontPens/
+ arch = any
+ license = BSD
+ checkdepends = python-fontmath
+ checkdepends = python-fontparts
+ checkdepends = python-pytest
+ checkdepends = python-unicodedata2>=12.0.0
+ makedepends = python-setuptools
+ depends = python
+ depends = python-fonttools
+ source = https://pypi.org/packages/source/f/fontPens/fontPens-0.2.4.zip
+ sha256sums = a6d9a14573b3450f3313d69523f9006028c21fc7aef5d35333b87aab7f2b41fd
+
+pkgname = python-fontpens
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de5a57e73204
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=('python-fontpens')
+_pkgname='fontPens'
+pkgver='0.2.4'
+pkgrel=1
+pkgdesc='A collection of classes implementing the pen protocol for manipulating glyphs.'
+url='https://pypi.org/project/fontPens/'
+checkdepends=('python-fontmath' 'python-fontparts' 'python-pytest' 'python-unicodedata2>=12.0.0')
+depends=('python' 'python-fonttools')
+makedepends=('python-setuptools')
+optdepends=()
+license=('BSD')
+arch=('any')
+source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip")
+sha256sums=('a6d9a14573b3450f3313d69523f9006028c21fc7aef5d35333b87aab7f2b41fd')
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt"
+}
+
+#check() {
+ #cd "$srcdir/$_pkgname-$pkgver"
+ #python setup.py test
+#}
+