summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2020-12-08 23:59:11 +0300
committerCaleb Maclennan2020-12-09 00:00:00 +0300
commite5452bfe5e5020608f985a6306be3f437c0879ba (patch)
tree0f51d139b825f344d1988236ebb626ad893d64c2
parent48c65102de6ea7f344e8d4abfac15fc226b97d97 (diff)
downloadaur-e5452bfe5e5020608f985a6306be3f437c0879ba.tar.gz
Re-instate Git package, patterned after [community]
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD96
2 files changed, 53 insertions, 74 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2b3392c3630a..9a8e761288ff 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,27 @@
pkgbase = python-fonttools-git
- pkgdesc = Modify OpenType and TrueType fonts and convert them to and from XML
- pkgver = 3.0.r1920
+ pkgdesc = A library to manipulate font files from Python
+ pkgver = 4.18.0.r8.g26f3ef0
pkgrel = 1
- url = https://github.com/behdad/fonttools
- arch = any
+ url = https://github.com/fonttools/fonttools
+ arch = x86_64
license = MIT
- makedepends = python2-setuptools
- makedepends = python-numpy
- makedepends = python2-numpy
+ makedepends = cython
depends = python
- source = git+https://github.com/behdad/fonttools.git
+ optdepends = python-lxml: faster backend for XML files reading/writing
+ optdepends = python-fs: to read/write UFO source files,
+ optdepends = python-brotli: to compress/decompress WOFF 2.0 web fonts
+ optdepends = python-zopfli: faster backend fom WOFF 1.0 web fonts compression
+ optdepends = python-scipy: for finding wrong contour/component order between different masters
+ optdepends = python-matplotlib: for visualizing DesignSpaceDocument and resulting VariationModel
+ optdepends = python-unicodedata2: for displaying the Unicode character names when dumping the cmap table with ttx
+ optdepends = python-sympy: for symbolic font statistics analysis
+ optdepends = python-pyqt5: for drawing glyphs with Qt's QPainterPath
+ optdepends = python-reportlab: to drawing glyphs as PNG images
+ optdepends = python-lz4: for graphite type tables in ttLib/tables
+ provides = python-fonttools=4.18.0.r8.g26f3ef0
+ conflicts = python-fonttools
+ source = python-fonttools-git::git+https://github.com/fonttools/fonttools.git
sha256sums = SKIP
pkgname = python-fonttools-git
- depends = python-numpy
-
-pkgname = python2-fonttools-git
- depends = python2-numpy
diff --git a/PKGBUILD b/PKGBUILD
index 3889147fbfd6..fbf27eb4dde6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,73 +1,45 @@
-_name=fonttools
-pkgbase=python-"$_name"-git
-pkgname=("python-$_name-git" "python2-$_name-git")
-pkgver=3.0.r1920
+# Maintainer: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=python-fonttools-git
+pkgver=4.18.0.r8.g26f3ef0
pkgrel=1
-pkgdesc='Modify OpenType and TrueType fonts and convert them to and from XML'
-arch=('any')
-url="https://github.com/behdad/$_name"
-license=('MIT')
-depends=('python')
-makedepends=("python2-setuptools" "python-numpy" "python2-numpy")
-#provides=("python-$_name" "python2-$_name")
-#conflicts=("python-$_name" "python2-$_name")
-source=("git+https://github.com/behdad/$_name.git")
+pkgdesc="A library to manipulate font files from Python"
+url="https://github.com/fonttools/fonttools"
+license=("MIT")
+arch=('x86_64')
+depends=("python")
+makedepends=("cython")
+optdepends=("python-lxml: faster backend for XML files reading/writing"
+ "python-fs: to read/write UFO source files, "
+ "python-brotli: to compress/decompress WOFF 2.0 web fonts"
+ "python-zopfli: faster backend fom WOFF 1.0 web fonts compression"
+ "python-scipy: for finding wrong contour/component order between different masters"
+ "python-matplotlib: for visualizing DesignSpaceDocument and resulting VariationModel"
+ "python-unicodedata2: for displaying the Unicode character names when dumping the cmap table with ttx"
+ "python-sympy: for symbolic font statistics analysis"
+ "python-pyqt5: for drawing glyphs with Qt's QPainterPath"
+ "python-reportlab: to drawing glyphs as PNG images"
+ "python-lz4: for graphite type tables in ttLib/tables")
+provides=("${pkgname%-git}=$pkgver")
+conflicts=("${pkgname%-git}")
+source=("$pkgname::git+$url.git")
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/$_name"
- printf "%s.r%s" \
- "$(git describe --abbrev=0 | sed 's/^v//')" \
- "$(git rev-list --count HEAD)"
-}
-
-prepare() {
- cd "$srcdir"
- cp -a fonttools fonttools-py2
- cd fonttools-py2
-
- sed -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
- -e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
- -e "s|#![ ]*/bin/env python$|#!/usr/bin/env python2|" \
- -i $(find . -name '*.py')
+ cd "$pkgname"
+ git describe --long --tags --abbrev=7 HEAD |
+ sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- msg "Building Python2"
-
- cd "$srcdir"/fonttools-py2
- python2 setup.py build
-
- msg "Building Python3"
- cd "$srcdir"/fonttools
- python setup.py build
+ cd $pkgname
+ python setup.py build_ext --inplace
+ python setup.py build
}
-package_python2-fonttools-git() {
- depends=("python2-numpy")
-
- cd "$srcdir"/fonttools-py2
-
- python2 setup.py install --skip-build --root="$pkgdir" --optimize=1
-
- # fix conflicts with python-fonttools
- mv "$pkgdir"/usr/bin/pyftinspect{,2}
- mv "$pkgdir"/usr/bin/pyftmerge{,2}
- mv "$pkgdir"/usr/bin/pyftsubset{,2}
- mv "$pkgdir"/usr/bin/ttx{,2}
- mv "$pkgdir"/usr/share/man/man1/ttx{,2}.1
-
- install -D -m755 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- chmod oga+r "$pkgdir"/usr/share/man/man1/ttx2.1
+package() {
+ cd $pkgname
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -D -m755 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-package_python-fonttools-git() {
- depends=("python-numpy")
-
- cd "$srcdir"/fonttools
-
- python setup.py install --skip-build --root="$pkgdir" --optimize=1
-
- install -D -m755 LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
- chmod oga+r "$pkgdir"/usr/share/man/man1/ttx.1
-}