summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Moch2017-12-15 14:32:33 -0500
committerDaniel Moch2017-12-15 14:32:33 -0500
commit560f75897170c796a72cea2d95285758578f3eb7 (patch)
treeb74ddcd77f17e153fdadf85ca139a1d865408932
downloadaur-560f75897170c796a72cea2d95285758578f3eb7.tar.gz
Initial commit for version 1.3.5
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e6ea9aad5871
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-forecastio
+ pkgdesc = A thin Python Wrapper for the Dark Sky (formerly Forecast.io) weather API
+ pkgver = 1.3.5
+ pkgrel = 1
+ url = http://zeevgilovitz.com/python-forecast.io
+ arch = any
+ license = BSD 2-clause
+ makedepends = python-setuptools
+ depends = python
+ depends = python-requests
+ depends = python-responses
+ provides = python-forecastio
+ conflicts = python-forecastio
+ source = https://pypi.python.org/packages/c4/ee/8db21a142548e4b67950068bd78034b67b04900efa79c44c3c2241a3450c/python-forecastio-1.3.5.tar.gz
+ sha512sums = 389e904921e5cbe62d05f9fd837cc8df0414b187858c4e13487d77b716935092c842d941a49a40b1dd6a91dc795f6d667164964f28c4f35b623be107ea08a409
+
+pkgname = python-forecastio
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d8495dd4fe2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Daniel Moch <daniel AT danielmoch DOT com>
+
+pkgname=python-forecastio
+pkgver=1.3.5
+pkgrel=1
+pkgdesc="A thin Python Wrapper for the Dark Sky (formerly Forecast.io) weather API"
+url="http://zeevgilovitz.com/python-forecast.io"
+license=('BSD 2-clause')
+arch=('any')
+depends=(
+'python'
+'python-requests'
+'python-responses')
+makedepends=('python-setuptools')
+provides=('python-forecastio')
+conflicts=('python-forecastio')
+source=(https://pypi.python.org/packages/c4/ee/8db21a142548e4b67950068bd78034b67b04900efa79c44c3c2241a3450c/python-forecastio-${pkgver}.tar.gz)
+sha512sums=('389e904921e5cbe62d05f9fd837cc8df0414b187858c4e13487d77b716935092c842d941a49a40b1dd6a91dc795f6d667164964f28c4f35b623be107ea08a409')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}/"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim: ts=2 sts=2 sw=2 et ft=sh