summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-12-17 16:27:33 -0500
committerGuillaume Horel2021-12-17 16:27:33 -0500
commit6cef5d54f5a3a1d35b840a9284586405935af79e (patch)
tree67521007fb8e3ed5755d3d02da20871e8b5a8f84
downloadaur-6cef5d54f5a3a1d35b840a9284586405935af79e.tar.gz
initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9702b60062e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-formulaic
+ pkgdesc = A high performance of Wilkinson formulas in Pythonn
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = https://github.com/matthewwardrop/formulaic
+ arch = any
+ license = MIT
+ checkdepends = python-pytest
+ makedepends = python-setupmeta
+ makedepends = python-setuptools
+ depends = python
+ depends = python-astor
+ depends = python-numpy
+ depends = python-pandas
+ depends = python-scipy
+ depends = python-wrapt
+ source = https://files.pythonhosted.org/packages/source/f/formulaic/formulaic-0.2.4.tar.gz
+ sha256sums = 15b71ea8972fb451f80684203cddd49620fc9ed5c2e35f31e0874e9c41910d1a
+
+pkgname = python-formulaic
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..067c28a4830e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname='python-formulaic'
+_pkgname='formulaic'
+pkgver='0.2.4'
+pkgrel=1
+pkgdesc="A high performance of Wilkinson formulas in Pythonn"
+url="https://github.com/matthewwardrop/formulaic"
+depends=('python'
+ 'python-astor'
+ 'python-numpy'
+ 'python-pandas'
+ 'python-scipy'
+ 'python-wrapt')
+checkdepends=('python-pytest')
+optdepends=()
+makedepends=('python-setupmeta' 'python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+sha256sums=('15b71ea8972fb451f80684203cddd49620fc9ed5c2e35f31e0874e9c41910d1a')
+
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
+}
+
+check() {
+ cd "${_pkgname}-${pkgver}"
+ PYTHONPATH=. pytest tests
+}