summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2022-03-24 11:05:41 -0400
committerGuillaume Horel2022-03-24 11:05:41 -0400
commitea59c7f0218cc81de94ebf09e34fe650fce152e7 (patch)
tree7f7f0eaad55ffb8b9bb2811eb1ae4247a63f3783
parent6cef5d54f5a3a1d35b840a9284586405935af79e (diff)
downloadaur-ea59c7f0218cc81de94ebf09e34fe650fce152e7.tar.gz
bump to 0.3.2
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9702b60062e8..c792038933f2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-formulaic
pkgdesc = A high performance of Wilkinson formulas in Pythonn
- pkgver = 0.2.4
+ pkgver = 0.3.2
pkgrel = 1
url = https://github.com/matthewwardrop/formulaic
arch = any
@@ -14,7 +14,8 @@ pkgbase = python-formulaic
depends = python-pandas
depends = python-scipy
depends = python-wrapt
- source = https://files.pythonhosted.org/packages/source/f/formulaic/formulaic-0.2.4.tar.gz
- sha256sums = 15b71ea8972fb451f80684203cddd49620fc9ed5c2e35f31e0874e9c41910d1a
+ optdepends = python-sympy
+ source = https://files.pythonhosted.org/packages/source/f/formulaic/formulaic-0.3.2.tar.gz
+ sha256sums = 3e16262562147acbdeda1178d778ac189a93bd63e2348261bd8b5d303f173f6d
pkgname = python-formulaic
diff --git a/PKGBUILD b/PKGBUILD
index 067c28a4830e..e515fd899cbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname='python-formulaic'
_pkgname='formulaic'
-pkgver='0.2.4'
+pkgver='0.3.2'
pkgrel=1
pkgdesc="A high performance of Wilkinson formulas in Pythonn"
url="https://github.com/matthewwardrop/formulaic"
@@ -12,12 +12,12 @@ depends=('python'
'python-scipy'
'python-wrapt')
checkdepends=('python-pytest')
-optdepends=()
+optdepends=('python-sympy')
makedepends=('python-setupmeta' 'python-setuptools')
license=('MIT')
arch=('any')
source=("https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
-sha256sums=('15b71ea8972fb451f80684203cddd49620fc9ed5c2e35f31e0874e9c41910d1a')
+sha256sums=('3e16262562147acbdeda1178d778ac189a93bd63e2348261bd8b5d303f173f6d')
build() {
cd "${_pkgname}-${pkgver}"
@@ -30,7 +30,7 @@ package() {
install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}
-check() {
- cd "${_pkgname}-${pkgver}"
- PYTHONPATH=. pytest tests
-}
+#check() {
+ #cd "${_pkgname}-${pkgver}"
+ #PYTHONPATH=. pytest tests
+#}