summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-02-05 20:01:18 +0100
committerPhilipp A2019-02-05 20:01:18 +0100
commitd89cafa9cbfecb79efb8fab6906076b00e4bf984 (patch)
tree9c7656d66546f162565e8f3cad4ab49d70a7360e
downloadaur-d89cafa9cbfecb79efb8fab6906076b00e4bf984.tar.gz
init
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD18
3 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c21d1e9e06bc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-fpdf
+ pkgdesc = Simple PDF generation for Python
+ pkgver = 1.7.2
+ pkgrel = 1
+ url = https://github.com/reingart/pyfpdf
+ arch = any
+ license = GPL3
+ makedepends = pandoc
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/f/fpdf/fpdf-1.7.2.tar.gz
+ sha256sums = 125840783289e7d12552b1e86ab692c37322e7a65b96a99e0ea86cca041b6779
+
+pkgname = python-fpdf
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8bba9d8c732d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.tar.gz
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..81b88e4cc417
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+_name=fpdf
+pkgname=python-$_name
+pkgver=1.7.2
+pkgrel=1
+pkgdesc='Simple PDF generation for Python'
+arch=(any)
+url='https://github.com/reingart/pyfpdf'
+license=(GPL3)
+depends=(python)
+makedepends=(pandoc)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('125840783289e7d12552b1e86ab692c37322e7a65b96a99e0ea86cca041b6779')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 || return 1
+}