summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2021-02-27 14:00:58 -0500
committerGuillaume Horel2021-02-27 14:00:58 -0500
commit9bf39f48dd430dd89f62b95935254cb35bbba3ce (patch)
treec9c8c1f96052f5f4e83670f9492379a4e6d12cd1
downloadaur-9bf39f48dd430dd89f62b95935254cb35bbba3ce.tar.gz
initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ec46e5bbac6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-fpdf2
+ pkgdesc = Simple PDF generation for Python
+ pkgver = 2.3.0
+ pkgrel = 1
+ url = https://pyfpdf.github.io/fpdf2/
+ arch = any
+ license = LGPL3
+ makedepends = python-setuptools
+ depends = python-pillow
+ conflicts = python-fpdf
+ source = https://files.pythonhosted.org/packages/source/f/fpdf2/fpdf2-2.3.0.tar.gz
+ sha256sums = a7583954ab7f9664c43ed1a3e523ee23f42649b366680f03b9a2397c795087ef
+
+pkgname = python-fpdf2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..238e876aa682
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
+pkgname=python-fpdf2
+_name=${pkgname#python-}
+pkgver=2.3.0
+pkgrel=1
+pkgdesc='Simple PDF generation for Python'
+arch=(any)
+url='https://pyfpdf.github.io/fpdf2/'
+license=(LGPL3)
+conflicts=('python-fpdf')
+depends=('python-pillow')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('a7583954ab7f9664c43ed1a3e523ee23f42649b366680f03b9a2397c795087ef')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+}