summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranco Masotti2023-01-05 18:20:11 +0100
committerFranco Masotti2023-01-05 18:20:35 +0100
commit5397d91ff1cc0225e9c650ffdc369d44a920a0fb (patch)
tree3a8ae131fb875eef0e6d2f4b93c79a86cac0490e
parentd7fa7ba59f232a065218236d2ed0bcb9d7d840a0 (diff)
downloadaur-5397d91ff1cc0225e9c650ffdc369d44a920a0fb.tar.gz
New release.
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD26
2 files changed, 24 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8adc7589f4ba..108158d25c94 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = python-fpyutils
pkgdesc = A collection of useful non-standard Python functions which aim to be simple to use
- pkgver = 3.0.0
+ pkgver = 3.0.1
pkgrel = 1
url = https://blog.franco.net.eu.org/software/#fpyutils
arch = any
license = GPL3
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
makedepends = python-setuptools
depends = python
options = !emptydirs
- source = https://blog.franco.net.eu.org/software/fpyutils-3.0.0/fpyutils-3.0.0.tar.gz.sig
- source = https://blog.franco.net.eu.org/software/fpyutils-3.0.0/fpyutils-3.0.0.tar.gz
+ source = https://blog.franco.net.eu.org/software/fpyutils-3.0.1/fpyutils-3.0.1.tar.gz.sig
+ source = https://blog.franco.net.eu.org/software/fpyutils-3.0.1/fpyutils-3.0.1.tar.gz
sha512sums = SKIP
- sha512sums = 2b6b23ba65b258801b9cc71a794b49d125b62761dc1e8e455fcc8cac0d21123f177e69b46d0e59eb9e5f91693fbb8da09675d276d8eb3d0428b16a4d01546b32
+ sha512sums = 8aa0fcefada2bebe76f5d9033f54efaf9652cc8deb0a8e6015f27fdb0c83f49e12fec1790462d07f6cc56cb20a270df199091633e1992fae02bea136254de35d
pkgname = python-fpyutils
diff --git a/PKGBUILD b/PKGBUILD
index 511d4b0f47b1..43b0e3598e99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,32 @@
-# Maintainer: Franco Masotti <franco dot masotti at live dot com>
-# Contributor: Franco Masotti <franco dot masotti at live dot com>
+# Maintainer: Franco Masotti <franco dot masotti at tutanota dot com>
+# Contributor: Franco Masotti <franco dot masotti at tutanota dot com>
pkgname=python-fpyutils
-pkgver=3.0.0
+pkgver=3.0.1
pkgrel=1
pkgdesc="A collection of useful non-standard Python functions which aim to be simple to use"
arch=('any')
url="https://blog.franco.net.eu.org/software/#fpyutils"
license=('GPL3')
depends=('python')
-makedepends=('python-setuptools')
+makedepends=('python-build'
+ 'python-installer'
+ 'python-wheel'
+ 'python-setuptools')
options=(!emptydirs)
source=("https://blog.franco.net.eu.org/software/fpyutils-${pkgver}/fpyutils-${pkgver}.tar.gz.sig" "https://blog.franco.net.eu.org/software/fpyutils-${pkgver}/fpyutils-${pkgver}.tar.gz")
-sha512sums=('SKIP' '2b6b23ba65b258801b9cc71a794b49d125b62761dc1e8e455fcc8cac0d21123f177e69b46d0e59eb9e5f91693fbb8da09675d276d8eb3d0428b16a4d01546b32')
+sha512sums=('SKIP' '8aa0fcefada2bebe76f5d9033f54efaf9652cc8deb0a8e6015f27fdb0c83f49e12fec1790462d07f6cc56cb20a270df199091633e1992fae02bea136254de35d')
check() {
- cd "${srcdir}"/fpyutils-"${pkgver}"
- python -m unittest discover --failfast --locals --verbose
+ cd "${srcdir}"/fpyutils-"${pkgver}"
+ python -m unittest discover --failfast --locals --verbose
+}
+
+build() {
+ cd "${srcdir}"/fpyutils-"${pkgver}"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}"/fpyutils-"${pkgver}"
- python setup.py install --root="${pkgdir}/" --optimize=1
+ cd "${srcdir}"/fpyutils-"${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}