summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFranco Masotti2018-03-25 17:33:06 +0200
committerFranco Masotti2018-03-25 17:33:06 +0200
commitd4a4d67a6d1bf976eefe3de473fe15a137ba5b7e (patch)
treed551a9ebd44a510a068b0d37845a41928bdf0faa
downloadaur-d4a4d67a6d1bf976eefe3de473fe15a137ba5b7e.tar.gz
First commit.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD26
2 files changed, 41 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6755fd3f031f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-fpyutils
+ pkgdesc = A collection of useful non-standard Python functions which aim to be simple to use
+ pkgver = 0.0.3
+ pkgrel = 1
+ url = https://github.com/frnmst/fpyutils
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ options = !emptydirs
+ source = python-fpyutils.tar.gz::https://github.com/frnmst/fpyutils/archive/0.0.3.tar.gz
+ sha256sums = faee6481524ff58aef0ae75fac788bb8dc943dcd2fbf8a2d8343e845a84e6dc6
+
+pkgname = python-fpyutils
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..877709235f0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Franco Masotti <franco dot masotti at student dot unife dot it>
+# Contributor: Franco Masotti <franco dot masotti at student dot unife dot it>
+pkgname=python-fpyutils
+pkgver=0.0.3
+pkgrel=1
+pkgdesc="A collection of useful non-standard Python functions which aim to be simple to use"
+arch=('any')
+url="https://github.com/frnmst/fpyutils"
+license=('GPL3')
+depends=('python')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+source=("${pkgname}.tar.gz::https://github.com/frnmst/fpyutils/archive/${pkgver}.tar.gz")
+sha256sums=('faee6481524ff58aef0ae75fac788bb8dc943dcd2fbf8a2d8343e845a84e6dc6')
+
+check() {
+ cd "${srcdir}"/fpyutils-"${pkgver}"
+ python setup.py test
+}
+
+package() {
+ cd "${srcdir}"/fpyutils-"${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}
+
+