summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Gamble2021-08-17 18:50:27 +1000
committerMatthew Gamble2021-08-17 18:50:27 +1000
commit1a810b1205f1835d000973044fc2206777a12e86 (patch)
tree6dca59aee3d10747ba60ffe657e51474269aaac3
downloadaur-1a810b1205f1835d000973044fc2206777a12e86.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD33
3 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9aa88a7c7ff4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-freiner
+ pkgdesc = Generic rate limiting solution for python applications, supporting various strategies and storage backends.
+ pkgver = 3.0.4
+ pkgrel = 1
+ url = https://github.com/djmattyg007/freiner/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-typing_extensions
+ source = https://pypi.io/packages/source/f/freiner/freiner-3.0.4.tar.gz
+ sha256sums = b9e660460c9b194b160233d0a59ce1b1968ea43d7b5798972c84bb17594f205f
+
+pkgname = python-freiner
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e38eb34d4ee1
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+*.pkg.tar.*
+*.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ffb753cc52d4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Matthew Gamble <git@matthewgamble.net>
+
+pkgname=python-freiner
+pkgver=3.0.4
+pkgrel=1
+pkgdesc="Generic rate limiting solution for python applications, supporting various strategies and storage backends."
+arch=("any")
+url="https://github.com/djmattyg007/freiner/"
+license=("MIT")
+depends=("python" "python-typing_extensions")
+makedepends=("python-setuptools")
+# Right now pymemcache doesn't even build, and I still have to package python-rediscluster
+#makedepends=("python-setuptools" "python-sphinx" "python-sphinx_rtd_theme" "python-pymemcache" "python-redis" "python-rediscluster")
+source=("https://pypi.io/packages/source/f/freiner/freiner-${pkgver}.tar.gz")
+sha256sums=("b9e660460c9b194b160233d0a59ce1b1968ea43d7b5798972c84bb17594f205f")
+
+build() {
+ cd "freiner-${pkgver}"
+
+ python setup.py build
+
+ #cd docs
+ #sphinx-build -nb html -d build/doctrees . build/html
+}
+
+package() {
+ cd "freiner-${pkgver}"
+
+ PYTHONHASHSEED=0 python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/freiner/LICENSE.txt"
+ install -Dm644 CHANGELOG.rst "${pkgdir}/usr/share/doc/python-humanfriendly/CHANGELOG.rst"
+ #cp -r docs/build/html "${pkgdir}/usr/share/doc/python-humanfriendly/html"
+}