summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Landau2015-06-27 17:55:59 +0300
committerDaniel Landau2015-06-27 17:55:59 +0300
commitd7ea01b5ba44f525807c5f72ef10307149c13b31 (patch)
tree9f4b2cfbe56a5754e595416776f78203c4fc7ff4
downloadaur-d7ea01b5ba44f525807c5f72ef10307149c13b31.tar.gz
Initial migration from old AUR
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8cfd7d0c4d6f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-ftfy-git
+ pkgdesc = Fixes some problems with Unicode text after the fact
+ pkgver = r194.7f025a2
+ pkgrel = 1
+ url = https://github.com/LuminosoInsight/python-ftfy
+ arch = any
+ license = MIT
+ makedepends = python
+ makedepends = python-setuptools
+ depends = python
+ source = git+https://github.com/LuminosoInsight/python-ftfy.git
+ sha256sums = SKIP
+
+pkgname = python-ftfy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f37c521b64bf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: lucy <lucy@luz.lu>
+
+pkgname=python-ftfy-git
+_gitname=python-ftfy
+pkgver=r194.7f025a2
+pkgrel=1
+pkgdesc='Fixes some problems with Unicode text after the fact'
+url="https://github.com/LuminosoInsight/python-ftfy"
+arch=('any')
+license=('MIT')
+makedepends=('python' 'python-setuptools')
+depends=('python')
+source=('git+https://github.com/LuminosoInsight/python-ftfy.git')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_gitname"
+ python setup.py install --prefix=/usr --root="$pkgdir"
+ install -Dm644 LICENSE.txt \
+ "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}