summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Neumann2022-01-19 12:47:33 +0100
committerRichard Neumann2022-01-19 12:47:33 +0100
commitbde6fc59a6b700d874a40d3a71851c0db413e1ee (patch)
tree480472740a4bdd061060ab49b63bfa1e98f75bcc
downloadaur-bde6fc59a6b700d874a40d3a71851c0db413e1ee.tar.gz
Init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c505ffbeee60
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-functoolsplus
+ pkgdesc = More higher-order functions and operations on callable objects.
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/coNQP/functoolsplus
+ arch = any
+ license = GPLv3
+ makedepends = git
+ makedepends = python
+ makedepends = python-pytest
+ makedepends = python-setuptools
+ makedepends = python-setuptools-scm
+ depends = python
+ source = functoolsplus::git+https://github.com/coNQP/functoolsplus.git#tag=1.0.0
+ md5sums = SKIP
+
+pkgname = python-functoolsplus
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cc6fe4d7c9c3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Richard Neumann aka. schard <mail at richard dash neumann period de>
+
+_pkgbase='functoolsplus'
+pkgname="python-${_pkgbase}"
+pkgver=1.0.0
+pkgrel=1
+pkgdesc='More higher-order functions and operations on callable objects.'
+arch=('any')
+url="https://github.com/coNQP/${_pkgbase}"
+license=('GPLv3')
+depends=('python')
+makedepends=('git' 'python' 'python-pytest' 'python-setuptools' 'python-setuptools-scm')
+source=("${_pkgbase}::git+${url}.git#tag=${pkgver}")
+md5sums=('SKIP')
+
+
+package() {
+ cd "${srcdir}/${_pkgbase}"
+ python setup.py install --root "${pkgdir}" --optimize=1
+}