summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Neumann2022-01-19 15:00:43 +0100
committerRichard Neumann2022-01-19 15:00:43 +0100
commitc50202cbf40cba81a1607f68a5e1bf8c74faec84 (patch)
tree1f2459bb9e0df8a9ce2ff3e85e798cbac6264dda
parent5907273f67d6f6857a86ccdbea69525e1dfa8cde (diff)
downloadaur-c50202cbf40cba81a1607f68a5e1bf8c74faec84.tar.gz
Update dependencies and build functions
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 10 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5149359d1bf9..1e852125fda7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
pkgbase = python-functoolsplus
pkgdesc = More higher-order functions and operations on callable objects.
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/homeinfogmbh/functoolsplus
arch = any
license = GPLv3
makedepends = git
makedepends = python
makedepends = python-pytest
- makedepends = python-setuptools
makedepends = python-setuptools-scm
depends = python
+ depends = python-setuptools
source = functoolsplus::git+https://github.com/homeinfogmbh/functoolsplus.git#tag=1.0.0
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index abc93b10c6ef..a49028154f9c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,27 @@
_pkgbase='functoolsplus'
pkgname="python-${_pkgbase}"
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='More higher-order functions and operations on callable objects.'
arch=('any')
url="https://github.com/homeinfogmbh/${_pkgbase}"
license=('GPLv3')
-depends=('python')
-makedepends=('git' 'python' 'python-pytest' 'python-setuptools' 'python-setuptools-scm')
+depends=('python' 'python-setuptools')
+makedepends=('git' 'python' 'python-pytest' 'python-setuptools-scm')
source=("${_pkgbase}::git+${url}.git#tag=${pkgver}")
md5sums=('SKIP')
-
check() {
cd "${srcdir}/${_pkgbase}"
pytest
}
+build() {
+ cd "${srcdir}/${_pkgbase}"
+ python setup.py build
+}
package() {
cd "${srcdir}/${_pkgbase}"
- python setup.py install --root "${pkgdir}" --optimize=1
+ python setup.py install --root "${pkgdir}" --optimize=1 --skip-build
}