summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAchmad Fathoni2022-03-21 17:48:30 +0700
committerAchmad Fathoni2022-03-21 17:48:30 +0700
commit769c09aa6a717ee3136927624645d43f8c922b59 (patch)
tree20f9a4e47953baf6c54404c47560eb18bcd9f9eb
downloadaur-769c09aa6a717ee3136927624645d43f8c922b59.tar.gz
Init
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD23
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ed9230b24de6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-fundamentalanalysis
+ pkgdesc = Fully-fledged Fundamental Analysis package
+ pkgver = 0.2.12
+ pkgrel = 1
+ url = https://pypi.org/project/FundamentalAnalysis
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python
+ depends = python-requests
+ depends = python-pandas
+ source = https://files.pythonhosted.org/packages/source/F/FundamentalAnalysis/FundamentalAnalysis-0.2.12.tar.gz
+ sha256sums = 360576a7e75cc576860a0de086cdd33522433932b90326830945b27c519051d3
+
+pkgname = python-fundamentalanalysis
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b5ca84e8d7f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Achmad Fathoni<fathoni.id(at)gmail.com>
+pkgname=python-fundamentalanalysis
+_pkgname=FundamentalAnalysis
+pkgver=0.2.12
+pkgrel=1
+pkgdesc="Fully-fledged Fundamental Analysis package"
+arch=('any')
+url="https://pypi.org/project/${_pkgname}"
+license=('MIT')
+makedepends=(python-build python-installer python-wheel)
+depends=(python python-requests python-pandas)
+source=(https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz)
+sha256sums=('360576a7e75cc576860a0de086cdd33522433932b90326830945b27c519051d3')
+
+build() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd ${srcdir}/${_pkgname}-${pkgver}
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}