summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUncle Hunto2016-06-23 01:06:04 -0700
committerUncle Hunto2016-06-23 01:06:04 -0700
commit814d9ae5d641e44b20e0dde79373f72e16bdeec8 (patch)
tree2e68ae320128cb39bb731f07293c40ea888da708
downloadaur-814d9ae5d641e44b20e0dde79373f72e16bdeec8.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6cc1e826d22f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Tue Jun 14 02:26:18 UTC 2016
+pkgbase = python-fusepy-git
+ pkgdesc = Simple ctypes bindings for FUSE
+ pkgver = 2.0.2.r1.g27d76e4
+ pkgrel = 1
+ url = https://github.com/terencehonles/fusepy
+ arch = any
+ license = custom:ISCL
+ makedepends = python-setuptools
+ depends = fuse>=2.6
+ depends = python
+ source = git+https://github.com/terencehonles/fusepy.git
+ md5sums = SKIP
+
+pkgname = python-fusepy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74bcb8f96a90
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Étienne André <eti.andre@gmail.com>
+pkgname='python-fusepy-git'
+pkgver=2.0.4.r0.g0eafeb5
+pkgrel=1
+pkgdesc='Simple ctypes bindings for FUSE'
+url='https://github.com/terencehonles/fusepy'
+arch=('any')
+license=('custom:ISCL')
+depends=('fuse>=2.6' 'python')
+makedepends=('python-setuptools')
+source=('git+https://github.com/terencehonles/fusepy.git')
+md5sums=('SKIP')
+
+pkgver() {
+ cd fusepy
+ git describe --long --tags | sed -r 's/^v//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${srcdir}/fusepy"
+ python setup.py install --root="$pkgdir/" --optimize=1
+
+ sed -n '/Copyright/,/ THIS SOFTWARE[.]/p' fuse.py > LICENSE
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}