summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCayetano Santos2020-03-08 19:41:37 +0100
committerCayetano Santos2020-03-08 19:41:37 +0100
commit1b7ec8a8ebeaa1abe226835a0fe5ccee7eb5f83d (patch)
treefbc498af47965a61ab1ed521106d16d1bde4e16b
downloadaur-1b7ec8a8ebeaa1abe226835a0fe5ccee7eb5f83d.tar.gz
First version
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD25
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8236d230599f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-fusesoc
+ pkgdesc = Coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python
+ pkgver = 1.9
+ pkgrel = 0
+ url = http://github.com/olofk/fusesoc/
+ arch = any
+ license = GPLv3
+ makedepends = python-setuptools
+ depends = python
+ depends = python-edalize
+ optdepends = iverilog: for simulating verilog designs
+ optdepends = ghdl: for simulating VHDL designs
+ provides = python-fusesoc
+ conflicts = python-fusesoc-git
+ options = !emptydirs
+ source = https://github.com/olofk/fusesoc/releases/download/1.9/fusesoc-1.9.tar.gz
+ md5sums = eec2d6fd3c8c68ce00b2eae7edb8e1a7
+
+pkgname = python-fusesoc
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2fbea5b90b8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: csantosb <csantosb dot inventati dot org>
+pkgname=python-fusesoc
+pkgver=1.9
+pkgrel=0
+pkgdesc="Coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python"
+arch=('any')
+url="http://github.com/olofk/fusesoc/"
+license=('GPLv3')
+conflicts=('python-fusesoc-git')
+provides=('python-fusesoc')
+depends=('python' 'python-edalize')
+
+makedepends=('python-setuptools')
+optdepends=('iverilog: for simulating verilog designs'
+ 'ghdl: for simulating VHDL designs')
+
+options=(!emptydirs)
+source=("https://github.com/olofk/fusesoc/releases/download/$pkgver/fusesoc-$pkgver.tar.gz")
+md5sums=('eec2d6fd3c8c68ce00b2eae7edb8e1a7')
+
+package() {
+ cd "${srcdir}/fusesoc-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
+ install -m 644 -D ./LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+}