summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCayetano Santos2020-03-16 20:11:39 +0100
committerCayetano Santos2020-03-16 20:11:39 +0100
commit379d2a1afb8d7a17dae77a04149a4beb499f1adf (patch)
tree6e25d03f5ba0400410908bdc37601878285236a0
parent0ef6472489c417b1a1705b5c573d55372941acc6 (diff)
downloadaur-379d2a1afb8d7a17dae77a04149a4beb499f1adf.tar.gz
release 1.10
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 7132b2c170d3..8d111efd5e06 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: csantosb <csantosb dot inventati dot org>
pkgname=python-fusesoc
-pkgver=1.9
+pkgver=1.10
pkgrel=0
pkgdesc="Coroutine based cosimulation library for writing VHDL and Verilog testbenches in Python"
arch=('any')
@@ -15,11 +15,11 @@ optdepends=('iverilog: for simulating verilog designs'
'ghdl: for simulating VHDL designs')
options=(!emptydirs)
-source=("https://github.com/olofk/fusesoc/releases/download/$pkgver/fusesoc-$pkgver.tar.gz")
-md5sums=('eec2d6fd3c8c68ce00b2eae7edb8e1a7')
+source=("git+https://github.com/olofk/fusesoc#tag=${pkgver}")
+md5sums=('SKIP')
package() {
- cd "${srcdir}/fusesoc-$pkgver"
+ cd "${srcdir}/fusesoc"
python setup.py install --prefix=/usr --root="$pkgdir/" --optimize=1
install -m 644 -D ./LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
}