summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCayetano Santos2020-04-29 19:19:17 +0200
committerCayetano Santos2020-04-29 19:19:17 +0200
commita50386a3fd1731a6c543e162e0e10f29136a085d (patch)
treefcd0e03b6b280684b489c088cc7bccf70b11f40b
parent81c288304d876e7d3c4eae2f849491b120bc5d09 (diff)
downloadaur-a50386a3fd1731a6c543e162e0e10f29136a085d.tar.gz
jsonschema and jinja dependencies
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD2
2 files changed, 3 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 358c0fabcb81..7ff2f1d132b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,6 +11,8 @@ pkgbase = python-fusesoc
depends = python-edalize
depends = python-setuptools
depends = python-pyaml
+ depends = python-jsonschema
+ depends = python-jinja
optdepends = iverilog: for simulating verilog designs
optdepends = ghdl: for simulating VHDL designs
optdepends = gtkwave: for visualizing waveforms
@@ -21,4 +23,3 @@ pkgbase = python-fusesoc
md5sums = SKIP
pkgname = python-fusesoc
-
diff --git a/PKGBUILD b/PKGBUILD
index d520686027f1..407c491e7f65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ url="http://github.com/olofk/fusesoc/"
license=('GPLv3')
conflicts=('python-fusesoc-git')
provides=('python-fusesoc')
-depends=('python' 'python-edalize' 'python-setuptools' 'python-pyaml')
+depends=('python' 'python-edalize' 'python-setuptools' 'python-pyaml' 'python-jsonschema' 'python-jinja')
makedepends=('git' 'python-pip')
optdepends=('iverilog: for simulating verilog designs'