summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCayetano Santos2020-04-29 17:28:56 +0200
committerCayetano Santos2020-04-29 17:28:56 +0200
commitb8abb5b58a95aea9e463e2f2f1b06613f13f6faf (patch)
treeb3bf27d1be66f60d6b4f06108b12e41b0dcba032
parented80fc7a8ef1fc39aa9324fa8fa22cc774ad4744 (diff)
downloadaur-b8abb5b58a95aea9e463e2f2f1b06613f13f6faf.tar.gz
include required simplesat with pip, not in the repos
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index d3042490f349..99a7c5f0c2f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -25,6 +25,8 @@ build() {
}
package() {
+ PIP_CONFIG_FILE=/dev/null pip install --isolated --root="$pkgdir" --ignore-installed --no-deps simplesat
+ python -O -m compileall "${pkgdir}/simplesat"
cd "${srcdir}/fusesoc"
python setup.py install --skip-build --root="$pkgdir" --optimize=1
install -m 644 -D ./LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE