summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2025-01-02 16:15:36 +0100
committerMichał Wojdyła2025-01-02 16:15:36 +0100
commit0912941be164836fd46b7c37b13bd085066c9b4d (patch)
treec47bdcaff3ddb9e0579a910c3b94445544d82326
parent3a270a91d272371718fe5df5c76fa42544ff85c0 (diff)
downloadaur-0912941be164836fd46b7c37b13bd085066c9b4d.tar.gz
reenable checks so it fails, add obnoxiously big install message
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD17
-rw-r--r--future.install27
3 files changed, 38 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f402083e56a..5fd272a48a57 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,9 @@
pkgbase = python-future
pkgdesc = Clean single-source support for Python 3 and 2
pkgver = 1.0.0
- pkgrel = 2
+ pkgrel = 3
url = https://python-future.org/
+ install = future.install
arch = any
license = MIT
makedepends = python-build
diff --git a/PKGBUILD b/PKGBUILD
index 8e6a2a28135c..37c31a957a16 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,3 +1,4 @@
+# Contributor: Michał Wojdyła < micwoj9292 at gmail dot com >
# Contributor: Felix Yan <felixonmars@archlinux.org>
# Contributor: Christopher Arndt <aur -at- chrisarndt -dot- de>
# Contributor: Gaute Hope <eg@gaute.vetsj.com>
@@ -5,7 +6,7 @@
pkgname=python-future
pkgver=1.0.0
-pkgrel=2
+pkgrel=3
pkgdesc="Clean single-source support for Python 3 and 2"
url="https://python-future.org/"
arch=('any')
@@ -18,19 +19,19 @@ optdepends=('python-setuptools: futurize and pasteurize scripts')
options=('!emptydirs')
source=("https://pypi.io/packages/source/f/future/future-$pkgver.tar.gz")
sha512sums=('8e28d53172e3ae7b3b27c424a48fb698a6e86bf1c648cdf74e7fd57d34901a9bda18429fe4e176d70be67fc6c80b7f961b3021356594e38b5f294406af40bc61')
-
+install=future.install
build() {
cd "$srcdir"/future-$pkgver
python -m build --wheel
}
# https://github.com/PythonCharmers/python-future/issues/640
# https://python-future.org/overview.html#status
-#check() {
-# cd "$srcdir"/future-$pkgver
-# # test_future needs python2 so it is disabled here
-# #PYTHONPATH="$PWD/build/lib:$PYTHONPATH" pytest -v tests/test_future
-# PYTHONPATH="$PWD/build/lib:$PYTHONPATH" pytest -v tests/test_past
-#}
+check() {
+ cd "$srcdir"/future-$pkgver
+ # test_future needs python2 so it is disabled here
+ #PYTHONPATH="$PWD/build/lib:$PYTHONPATH" pytest -v tests/test_future
+ PYTHONPATH="$PWD/build/lib:$PYTHONPATH" pytest -v tests/test_past
+}
package() {
cd future-$pkgver
diff --git a/future.install b/future.install
new file mode 100644
index 000000000000..1605565442fb
--- /dev/null
+++ b/future.install
@@ -0,0 +1,27 @@
+python_version_warning() {
+ echo ""
+ echo ""
+ echo ""
+ echo "WARNING: python-future package is not compatible with Python 3.13"
+ echo ""
+ echo ""
+ echo ""
+ echo "The python-future project was created in 2013 to attempt to save Python from the schism of version incompatibility that was threatening to tear apart the language (as Perl 6 contributed to the death of Perl)."
+ echo ""
+ echo "That time is now past. Thanks to a huge porting effort across the Python community, Python 3 eventually thrived. Python 2 reached its end of life in 2020 and the python-future package should no longer be necessary. Use it to help with porting legacy code to Python 3 but don’t depend on it for new code."
+ echo ""
+ echo ""
+ echo ""
+ echo "If you use packages that depend on it, please contact maintainers and/or upstream of these packages and try to work out whether this dependency is really needed."
+ echo ""
+ echo ""
+ echo ""
+}
+
+post_install() {
+ python_version_warning
+}
+
+post_upgrade() {
+ python_version_warning
+}