summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-03-11 15:28:27 +0100
committerPhilipp A2019-03-11 15:28:27 +0100
commit08c3d151cadb9390101033d7f940230595cd9b2f (patch)
tree0d5411fb8d2304703bdc9780eb1b67e9f89ad58a
parent1090fac6f7f60ac2c25a5e168f8a2ffaea599171 (diff)
downloadaur-08c3d151cadb9390101033d7f940230595cd9b2f.tar.gz
v1.0.0
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
2 files changed, 13 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a2a6f44518e4..07d0e49952b4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = python-future-fstrings
pkgdesc = A backport of fstrings to python<3.6
- pkgver = 0.4.5
+ pkgver = 1.0.0
pkgrel = 1
url = https://github.com/asottile/future-fstrings
arch = any
license = MIT
depends = python
- noextract = future_fstrings-0.4.5-py2.py3-none-any.whl
- source = https://files.pythonhosted.org/packages/py2.py3/f/future-fstrings/future_fstrings-0.4.5-py2.py3-none-any.whl
- sha256sums = 79c2f1b25d7c8d162d0a134471ec904090015122553742bb88c9ac1d60017136
+ noextract = future_fstrings-1.0.0-py2.py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py2.py3/f/future-fstrings/future_fstrings-1.0.0-py2.py3-none-any.whl
+ sha256sums = 928aac9e1879a9fc49b8d873cae4638ce5a70673a79199a9e3b97c821a61de11
pkgname = python-future-fstrings
diff --git a/PKGBUILD b/PKGBUILD
index 1ae82ff81dcf..658d3067cc25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=future-fstrings
pkgname=python-$_name
-pkgver=0.4.5
+pkgver=1.0.0
pkgrel=1
pkgdesc='A backport of fstrings to python<3.6'
arch=(any)
@@ -12,11 +12,18 @@ depends=(python)
_pyarch=py2.py3
_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
-sha256sums=('79c2f1b25d7c8d162d0a134471ec904090015122553742bb88c9ac1d60017136')
+sha256sums=('928aac9e1879a9fc49b8d873cae4638ce5a70673a79199a9e3b97c821a61de11')
noextract=("$_wheel")
package() {
local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
mkdir -p "$site"
unzip "$_wheel" -d "$site"
+
+ cat >future-fstrings-show.py <<-EOF
+ #!/usr/bin/env python3
+ from future_fstrings import main
+ main()
+ EOF
+ install -Dm755 future-fstrings-show.py "$pkgdir/usr/bin/future-fstrings-show"
}