summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-03-07 13:58:52 +0100
committerPhilipp A2019-03-07 13:58:52 +0100
commit1090fac6f7f60ac2c25a5e168f8a2ffaea599171 (patch)
tree52467b43b9216bd24aaa6dace7e1bc9456a18209
parent78d3190b648906eaf1a3c98a8253f5d6fe2b9ad1 (diff)
downloadaur-1090fac6f7f60ac2c25a5e168f8a2ffaea599171.tar.gz
v0.4.5
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
2 files changed, 13 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a743b20693fe..a2a6f44518e4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,14 @@
pkgbase = python-future-fstrings
pkgdesc = A backport of fstrings to python<3.6
- pkgver = 0.4.4
+ pkgver = 0.4.5
pkgrel = 1
url = https://github.com/asottile/future-fstrings
arch = any
license = MIT
- makedepends = python-pip
depends = python
- noextract = future_fstrings-0.4.4-py2.py3-none-any.whl
- source = https://files.pythonhosted.org/packages/py2.py3/f/future-fstrings/future_fstrings-0.4.4-py2.py3-none-any.whl
- sha256sums = ee4a9e4b8de317b1d43c01765d505a533d0d22d8e504bfa51c782ab1ababa5da
+ noextract = future_fstrings-0.4.5-py2.py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py2.py3/f/future-fstrings/future_fstrings-0.4.5-py2.py3-none-any.whl
+ sha256sums = 79c2f1b25d7c8d162d0a134471ec904090015122553742bb88c9ac1d60017136
pkgname = python-future-fstrings
diff --git a/PKGBUILD b/PKGBUILD
index c95781e1a0db..1ae82ff81dcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,22 @@
-# Maintainer: Phil Schaf <flying-sheep@web.de>
+# Maintainer: Philipp A. <flying-sheep@web.de>
_name=future-fstrings
pkgname=python-$_name
-pkgver=0.4.4
+pkgver=0.4.5
pkgrel=1
pkgdesc='A backport of fstrings to python<3.6'
arch=(any)
url="https://github.com/asottile/$_name"
license=(MIT)
depends=(python)
-makedepends=(python-pip)
-_wheel="${_name/-/_}-$pkgver-py2.py3-none-any.whl"
-source=("https://files.pythonhosted.org/packages/py2.py3/${_name::1}/$_name/$_wheel")
-sha256sums=('ee4a9e4b8de317b1d43c01765d505a533d0d22d8e504bfa51c782ab1ababa5da')
+_pyarch=py2.py3
+_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
+source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
+sha256sums=('79c2f1b25d7c8d162d0a134471ec904090015122553742bb88c9ac1d60017136')
noextract=("$_wheel")
package() {
- cd "$srcdir"
- pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+ local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
}