summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2018-12-05 11:33:05 +0100
committerPhilipp A2018-12-05 11:33:05 +0100
commit78d3190b648906eaf1a3c98a8253f5d6fe2b9ad1 (patch)
tree8d88cef8b265d043e522288653988b6d8e7cd659
downloadaur-78d3190b648906eaf1a3c98a8253f5d6fe2b9ad1.tar.gz
v0.4.4
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD21
3 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a743b20693fe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-future-fstrings
+ pkgdesc = A backport of fstrings to python<3.6
+ pkgver = 0.4.4
+ pkgrel = 1
+ url = https://github.com/asottile/future-fstrings
+ arch = any
+ license = MIT
+ makedepends = python-pip
+ depends = python
+ noextract = future_fstrings-0.4.4-py2.py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py2.py3/f/future-fstrings/future_fstrings-0.4.4-py2.py3-none-any.whl
+ sha256sums = ee4a9e4b8de317b1d43c01765d505a533d0d22d8e504bfa51c782ab1ababa5da
+
+pkgname = python-future-fstrings
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4d7ad300862e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/src/
+/pkg/
+/*.whl
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c95781e1a0db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Phil Schaf <flying-sheep@web.de>
+
+_name=future-fstrings
+pkgname=python-$_name
+pkgver=0.4.4
+pkgrel=1
+pkgdesc='A backport of fstrings to python<3.6'
+arch=(any)
+url="https://github.com/asottile/$_name"
+license=(MIT)
+depends=(python)
+makedepends=(python-pip)
+_wheel="${_name/-/_}-$pkgver-py2.py3-none-any.whl"
+source=("https://files.pythonhosted.org/packages/py2.py3/${_name::1}/$_name/$_wheel")
+sha256sums=('ee4a9e4b8de317b1d43c01765d505a533d0d22d8e504bfa51c782ab1ababa5da')
+noextract=("$_wheel")
+
+package() {
+ cd "$srcdir"
+ pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+}