summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-03-11 18:47:59 +0100
committerPhilipp A2019-03-11 18:47:59 +0100
commitd86d5b4a8119c19ba8f1e18eff9d7614275eaae6 (patch)
treee83a6249e1727a85a539b156d8a34663e130fe5b
parent08c3d151cadb9390101033d7f940230595cd9b2f (diff)
downloadaur-d86d5b4a8119c19ba8f1e18eff9d7614275eaae6.tar.gz
install-wheel-scripts
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD11
2 files changed, 5 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 07d0e49952b4..593b69b4f125 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = python-future-fstrings
pkgdesc = A backport of fstrings to python<3.6
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/asottile/future-fstrings
arch = any
license = MIT
+ makedepends = install-wheel-scripts
depends = python
noextract = future_fstrings-1.0.0-py2.py3-none-any.whl
source = https://files.pythonhosted.org/packages/py2.py3/f/future-fstrings/future_fstrings-1.0.0-py2.py3-none-any.whl
diff --git a/PKGBUILD b/PKGBUILD
index 658d3067cc25..7c39a1ef852e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,13 @@
_name=future-fstrings
pkgname=python-$_name
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc='A backport of fstrings to python<3.6'
arch=(any)
url="https://github.com/asottile/$_name"
license=(MIT)
depends=(python)
+makedepends=(install-wheel-scripts)
_pyarch=py2.py3
_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
@@ -19,11 +20,5 @@ package() {
local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
mkdir -p "$site"
unzip "$_wheel" -d "$site"
-
- cat >future-fstrings-show.py <<-EOF
- #!/usr/bin/env python3
- from future_fstrings import main
- main()
- EOF
- install -Dm755 future-fstrings-show.py "$pkgdir/usr/bin/future-fstrings-show"
+ install-wheel-scripts --prefix="$pkgdir/usr" "$_wheel"
}