summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Botting2020-06-22 14:41:13 +1000
committerAndy Botting2020-06-22 14:41:13 +1000
commit411f3222d56763d01455a6c0a870f0f21bc4b368 (patch)
tree706219a8cbc18feeaa18bce583da815558426f75
parentdf96b02e283fbd12e938f5a9b39ef0ceec32096e (diff)
downloadaur-411f3222d56763d01455a6c0a870f0f21bc4b368.tar.gz
Update to use stestr
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e4a8d209cd61..344f0d46e817 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = python-futurist
pkgdesc = Code from the future, delivered to you in the now.
pkgver = 2.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://docs.openstack.org/futurist/
arch = any
license = Apache
checkdepends = python-eventlet
checkdepends = python-oslotest
+ checkdepends = python-stestr
checkdepends = python-testrepository
checkdepends = python-testscenarios
checkdepends = python-testtools
diff --git a/PKGBUILD b/PKGBUILD
index 6c8fbd6417a9..cd6362af93a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=python-futurist
pkgver='2.2.0'
-pkgrel='1'
+pkgrel='2'
pkgdesc='Code from the future, delivered to you in the now.'
arch=('any')
url='https://docs.openstack.org/futurist/'
license=('Apache')
depends=('python-pbr' 'python-six' 'python-monotonic' 'python-prettytable'
'python-wheel')
-checkdepends=('python-eventlet' 'python-oslotest' 'python-testrepository'
- 'python-testscenarios' 'python-testtools')
+checkdepends=('python-eventlet' 'python-oslotest' 'python-stestr'
+ 'python-testrepository' 'python-testscenarios' 'python-testtools')
source=("https://github.com/openstack/futurist/archive/$pkgver.tar.gz")
sha512sums=('30c0186684a6f03ea6177978093a153f1c2c828a602fe76b1068dcd3feba93aa9791464f109321a2d2c3f7b32f4f76864493fdd225d2d4f9e81ac6fed3be1b4b')
@@ -23,7 +23,7 @@ build() {
check() {
cd futurist-$pkgver
- python setup.py test
+ stestr run
}
package() {