summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFelix Yan2020-10-12 11:13:33 +0000
committerFelix Yan2020-10-12 11:13:33 +0000
commit97dbc3550a411d71903ddefd2adcb33ed76e1993 (patch)
tree3c820ceba33c4a0a27511ca52257bf0966cf989e
downloadaur-97dbc3550a411d71903ddefd2adcb33ed76e1993.tar.gz
addpkg: 0.18.0-1
-rw-r--r--PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b5d666a3406
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: fenuks
+
+pkgname=python-fuzzywuzzy
+pkgver=0.18.0
+pkgrel=1
+pkgdesc="Fuzzy string matching like a boss"
+arch=("any")
+url="https://pypi.python.org/pypi/fuzzywuzzy"
+license=('GPL2')
+depends=('python')
+optdepends=('python-levenshtein: provides a 4-10x speedup in string matching')
+makedepends=('python-setuptools')
+checkdepends=('python-pytest' 'python-hypothesis' 'python-levenshtein' 'python-pycodestyle')
+source=("https://github.com/seatgeek/fuzzywuzzy/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha256sums=('26795bd6c319a8c789d62ecbe95e29a97711f0176d3beea04ce510981095f696')
+
+build() {
+ cd fuzzywuzzy-$pkgver
+ python setup.py build
+}
+
+check() {
+ cd fuzzywuzzy-$pkgver
+ # https://github.com/seatgeek/fuzzywuzzy/issues/284
+ pytest --deselect test_fuzzywuzzy_pytest.py::test_process_warning
+}
+
+package() {
+ cd fuzzywuzzy-$pkgver
+ python setup.py install --root="$pkgdir/" --optimize=1
+}