summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfenuks2015-09-11 20:47:33 +0200
committerfenuks2015-09-11 20:47:33 +0200
commitdc2d92b6f39dd69928c30470cb50c270608e1d36 (patch)
treed1e3c773302ac2ccf0e96020c5fd400e406da2a7
downloadaur-dc2d92b6f39dd69928c30470cb50c270608e1d36.tar.gz
Initial release
-rw-r--r--.SRCINFO19
-rw-r--r--LICENSE20
-rw-r--r--PKGBUILD31
3 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..40ae505d3613
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-fuzzywuzzy
+ pkgdesc = Fuzzy string matching like a boss
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/fuzzywuzzy
+ arch = any
+ license = custom:SeatGeek
+ makedepends = python-setuptools
+ depends = python
+ optdepends = python-levenshtein: provides a 4-10x speedup in string matching
+ conflicts = python-fuzzywuzzy
+ conflicts = python-fuzzywuzzy-git
+ source = https://pypi.python.org/packages/source/f/{fuzzywuzzy}/fuzzywuzzy-0.6.2.tar.gz
+ source = LICENSE
+ md5sums = c1fc05b65898a31e3517dda5fa657006
+ md5sums = afa01d831fdc3c0b681836e711f60f88
+
+pkgname = python-fuzzywuzzy
+
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ee0d12674a3b
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,20 @@
+Copyright (c) 2014 SeatGeek, Inc.
+
+Permission is hereby granted, free of charge, to any person obtaining
+a copy of this software and associated documentation files (the
+"Software"), to deal in the Software without restriction, including
+without limitation the rights to use, copy, modify, merge, publish,
+distribute, sublicense, and/or sell copies of the Software, and to
+permit persons to whom the Software is furnished to do so, subject to
+the following conditions:
+
+The above copyright notice and this permission notice shall be
+included in all copies or substantial portions of the Software.
+
+THE SOFTWARE IS PROVIDED "AS IS", WITHOUT WARRANTY OF ANY KIND,
+EXPRESS OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE WARRANTIES OF
+MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND
+NONINFRINGEMENT. IN NO EVENT SHALL THE AUTHORS OR COPYRIGHT HOLDERS BE
+LIABLE FOR ANY CLAIM, DAMAGES OR OTHER LIABILITY, WHETHER IN AN ACTION
+OF CONTRACT, TORT OR OTHERWISE, ARISING FROM, OUT OF OR IN CONNECTION
+WITH THE SOFTWARE OR THE USE OR OTHER DEALINGS IN THE SOFTWARE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4610dcb7311f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: fenuks
+
+_pkgname=fuzzywuzzy
+pkgname=python-${_pkgname}
+pkgver=0.6.2
+pkgrel=1
+pkgdesc="Fuzzy string matching like a boss"
+arch=("any")
+url="https://pypi.python.org/pypi/${_pkgname}"
+license=("custom:SeatGeek")
+depends=("python")
+optdepends=('python-levenshtein: provides a 4-10x speedup in string matching')
+makedepends=("python-setuptools")
+conflicts=("${pkgname}" "${pkgname}-git")
+# install=$pkgname.install
+source=("https://pypi.python.org/packages/source/${_pkgname::1}/{$_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ "LICENSE")
+md5sums=('c1fc05b65898a31e3517dda5fa657006'
+ 'afa01d831fdc3c0b681836e711f60f88')
+
+build() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -d -m 755 ${pkgdir}/usr/share/licenses/${pkgname}
+ install -D -m 644 $srcdir/LICENSE ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE
+}