summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorxiota2023-05-29 14:38:07 -0700
committerxiota2023-05-29 14:38:07 -0700
commitb797797cd5dc1f06989c2f699b43538ca260286a (patch)
tree426e335f755bb7c607aab739632d408ce73b8b18
parent04a871c2acab5f38eace6c12d50365e7349f0ca2 (diff)
downloadaur-b797797cd5dc1f06989c2f699b43538ca260286a.tar.gz
update build/package
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD28
2 files changed, 21 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fce6687299b2..7cf74771c896 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,13 +6,14 @@ pkgbase = python-fuzzywuzzy-git
arch = any
license = GPL2
checkdepends = python-hypothesis
- checkdepends = python-levenshtein
checkdepends = python-pycodestyle
checkdepends = python-pytest
makedepends = git
+ makedepends = python-build
+ makedepends = python-installer
makedepends = python-setuptools
- depends = python
- optdepends = python-levenshtein: provides a 4-10x speedup in string matching
+ makedepends = python-wheel
+ depends = python-levenshtein
provides = python-fuzzywuzzy
conflicts = python-fuzzywuzzy
source = python-fuzzywuzzy::git+https://github.com/seatgeek/fuzzywuzzy#commit=9e3d2fe0d8c1b195696d5fbcda78c371dd4a6b8f
diff --git a/PKGBUILD b/PKGBUILD
index b2b40fd20101..58eb573325d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,38 @@
+# Maintainer:
# Contributor: Dobroslaw Kijowski [dobo] <dobo90_at_gmail.com>
+# last commit before project was renamed "thefuzz"
+# later commits break building
+_commit=9e3d2fe0d8c1b195696d5fbcda78c371dd4a6b8f
+
_pkgname=python-fuzzywuzzy
pkgname=$_pkgname-git
pkgver=0.18.0.r3.g9e3d2fe
-# this is the last commit before project was renamed "thefuzz"
-_commit=9e3d2fe0d8c1b195696d5fbcda78c371dd4a6b8f
pkgrel=1
pkgdesc='Fuzzy string matching in Python'
arch=(any)
-_url="https://pypi.python.org/pypi/fuzzywuzzy"
url="https://github.com/seatgeek/fuzzywuzzy"
license=('GPL2')
-depends=('python')
-provides=(${_pkgname})
-conflicts=(${provides[@]})
-optdepends=(
- 'python-levenshtein: provides a 4-10x speedup in string matching'
+
+depends=(
+ 'python-levenshtein'
)
makedepends=(
'git'
+ 'python-build'
+ 'python-installer'
'python-setuptools'
+ 'python-wheel'
)
checkdepends=(
'python-hypothesis'
- 'python-levenshtein'
'python-pycodestyle'
'python-pytest'
)
+
+provides=(${_pkgname})
+conflicts=(${provides[@]})
+
source=("$_pkgname"::"git+$url#commit=$_commit")
sha256sums=(SKIP)
@@ -37,7 +43,7 @@ pkgver() {
build() {
cd "$srcdir/$_pkgname"
- python setup.py build
+ python -m build --no-isolation --wheel
}
check() {
@@ -48,5 +54,5 @@ check() {
package() {
cd "$srcdir/$_pkgname"
- python setup.py install --root="$pkgdir" --optimize=1
+ python -m installer --destdir="$pkgdir" dist/*.whl
}