summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Luna2020-07-24 15:50:22 -0500
committerChristopher Luna2020-07-24 15:50:22 -0500
commitf6a80254c607aeee7cb417afda301245e292f0db (patch)
tree2a823c9ea6054dc4b7fcf94861a8aaff0e3cf915
downloadaur-f6a80254c607aeee7cb417afda301245e292f0db.tar.gz
First commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD34
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..867f8480624e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-g2p-blocks-git
+ pkgdesc = Enable bcache or LVM on existing block devices. Convert between raw partitions, logical volumes, and bcache devices witout moving data.
+ pkgver = 167
+ pkgrel = 1
+ url = https://github.com/g2p/blocks
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = pkg-config
+ makedepends = python>=3.3
+ makedepends = git
+ depends = python-pyparted
+ depends = python-augeas
+ depends = python-maintboot-git
+ provides = python-g2p-blocks
+ source = git+https://github.com/g2p/blocks.git
+ md5sums = SKIP
+
+pkgname = python-g2p-blocks-git
+ depends = python
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..95101d773093
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Contributor: chrisl echo archlinux@c2h0r1i2s4t5o6p7h8e9r-l3u4n1a.com|sed 's/[0-9]//g'
+
+_pkgname=blocks
+pkgname=python-g2p-${_pkgname}-git
+pkgver=167
+pkgrel=1
+pkgdesc="Enable bcache or LVM on existing block devices. Convert between raw partitions, logical volumes, and bcache devices witout moving data."
+url="https://github.com/g2p/blocks"
+arch=('i686' 'x86_64')
+license=('GPL3')
+makedepends=('pkg-config' 'python>=3.3' 'git')
+provides=("python-g2p-${_pkgname}")
+source=("git+https://github.com/g2p/${_pkgname}.git")
+depends=("python-pyparted" "python-augeas" "python-maintboot-git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd ${srcdir}/${_pkgname}
+ git rev-list --count HEAD
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+ python setup.py build
+}
+
+package() {
+ depends=('python')
+
+ cd "${srcdir}/${_pkgname}"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ install -Dm644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}