summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-09-14 01:02:48 +0800
committerUniversebenzene2019-09-14 01:02:48 +0800
commit3970df08005bf12876ed4bb583757ac02d419a1f (patch)
tree0f676ee01909c008eeb886c15ce7a889b8f4d9b9
parentc17166f2735dbe763a71e00c777cbf613f41e91c (diff)
downloadaur-3970df08005bf12876ed4bb583757ac02d419a1f.tar.gz
Add optdepends
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD15
2 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3d8e3f5ec4bb..a144e331cdb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-galpy
pkgdesc = Galactic Dynamics in python
pkgver = 1.5
- pkgrel = 1
+ pkgrel = 2
url = http://galpy.readthedocs.io/
arch = i686
arch = x86_64
@@ -17,10 +17,19 @@ pkgname = python-galpy
depends = python-matplotlib
optdepends = python-galpy-doc: Documentation for galpy
optdepends = gsl>=1.14: For some advanced features
+ optdepends = python-future: For some advanced features
+ optdepends = python-astropy: For Quantity support
+ optdepends = python-astroquery: For the Orbit.from_name initialization method
+ optdepends = python-numexpr: For or plotting arbitrary expressions of Orbit quantities
+ optdepends = python-pynbody-git: Foruse of SnapshotRZPotential and InterpSnapshotRZPotential
pkgname = python2-galpy
depends = python2-scipy
depends = python2-matplotlib
optdepends = python-galpy-doc: Documentation for galpy
optdepends = gsl>=1.14: For some advanced features
+ optdepends = python2-future: For some advanced features
+ optdepends = python2-astropy: For Quantity support
+ optdepends = python2-astroquery: For the Orbit.from_name initialization method
+ optdepends = python2-pynbody-git: Foruse of SnapshotRZPotential and InterpSnapshotRZPotential
diff --git a/PKGBUILD b/PKGBUILD
index 4e5160b4dece..b286cec0d27b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _pyname=${pkgbase#python-}
pkgname=("python-${_pyname}" "python2-${_pyname}")
#"python-${_pyname}-doc")
pkgver=1.5
-pkgrel=1
+pkgrel=2
pkgdesc="Galactic Dynamics in python"
arch=('i686' 'x86_64')
url="http://galpy.readthedocs.io/"
@@ -41,7 +41,11 @@ build() {
package_python2-galpy() {
depends=('python2-scipy' 'python2-matplotlib')
optdepends=('python-galpy-doc: Documentation for galpy'
- 'gsl>=1.14: For some advanced features')
+ 'gsl>=1.14: For some advanced features'
+ 'python2-future: For some advanced features'
+ 'python2-astropy: For Quantity support'
+ 'python2-astroquery: For the Orbit.from_name initialization method'
+ 'python2-pynbody-git: Foruse of SnapshotRZPotential and InterpSnapshotRZPotential')
cd ${srcdir}/${_pyname}-${pkgver}-py2
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
@@ -52,7 +56,12 @@ package_python2-galpy() {
package_python-galpy() {
depends=('python-scipy' 'python-matplotlib')
optdepends=('python-galpy-doc: Documentation for galpy'
- 'gsl>=1.14: For some advanced features')
+ 'gsl>=1.14: For some advanced features'
+ 'python-future: For some advanced features'
+ 'python-astropy: For Quantity support'
+ 'python-astroquery: For the Orbit.from_name initialization method'
+ 'python-numexpr: For or plotting arbitrary expressions of Orbit quantities'
+ 'python-pynbody-git: Foruse of SnapshotRZPotential and InterpSnapshotRZPotential')
cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"