summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-04-26 22:55:20 +0800
committerUniversebenzene2020-04-26 22:55:20 +0800
commit885028902537c93d17e4164d8048e1d445609679 (patch)
treee3cef5620c57afed63481385d5e75f45330a3f95
parent2868d98d7480930f31af51f1d878e2dac60f30b4 (diff)
downloadaur-885028902537c93d17e4164d8048e1d445609679.tar.gz
Update to version 1.6.0.post0
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD11
3 files changed, 12 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5dc0c1b934ad..de8098543f73 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = python-galpy-doc
pkgdesc = Documentation for galpy
- pkgver = 1.5
+ pkgver = 1.6.0.post0
pkgrel = 1
- url = http://galpy.readthedocs.io/
+ url = https://www.galpy.org
arch = i686
arch = x86_64
license = BSD
- makedepends = python-galpy=1.5
+ makedepends = python-galpy=1.6.0.post0
makedepends = python-sphinx
makedepends = python-future
makedepends = gsl
- source = https://github.com/jobovy/galpy/archive/v1.5.0.tar.gz
- md5sums = a4dae164cfdfe5fd0a9be0eb6026eda5
+ source = https://github.com/jobovy/galpy/archive/v1.6.0.post0.tar.gz
+ md5sums = 5ecad599bc324912ae2be8dffe11a357
pkgname = python-galpy-doc
diff --git a/.gitignore b/.gitignore
index 0d6e3b36c63a..e896dcd6056d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,5 +4,5 @@ pkg
*.tar.gz
*.tar.bz2
*.part
-*.pkg.tar.xz
+*.pkg.tar.*
*.log
diff --git a/PKGBUILD b/PKGBUILD
index 04b2702cf228..32ae08102e40 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Astro Benzene <universebenzene at sina dot com>
pkgname=python-galpy-doc
-pkgver=1.5
+pkgver=1.6.0.post0
pkgrel=1
pkgdesc="Documentation for galpy"
arch=('i686' 'x86_64')
-url="http://galpy.readthedocs.io/"
+url="https://www.galpy.org"
license=('BSD')
makedepends=("python-galpy=${pkgver}" 'python-sphinx' 'python-future' 'gsl')
-source=("https://github.com/jobovy/galpy/archive/v${pkgver}.0.tar.gz")
-md5sums=('a4dae164cfdfe5fd0a9be0eb6026eda5')
+source=("https://github.com/jobovy/galpy/archive/v${pkgver}.tar.gz")
+md5sums=('5ecad599bc324912ae2be8dffe11a357')
build() {
- cd ${srcdir}/galpy-${pkgver}.0/doc
+ cd ${srcdir}/galpy-${pkgver}/doc
make html
}
@@ -19,6 +19,7 @@ build() {
package() {
cd ${srcdir}/galpy-docs
+ install -D -m644 -t "${pkgdir}/usr/share/licenses/${pkgname}" ../galpy-${pkgver}/LICENSE
install -d -m755 "${pkgdir}/usr/share/doc/python-galpy/html"
cp -a * "${pkgdir}/usr/share/doc/python-galpy/html"
}