summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorandalenavals2017-10-30 15:53:46 -0200
committerandalenavals2017-10-30 15:53:46 -0200
commit2858829787a1f632879d988a0692ad940e7f96bd (patch)
tree1f1eb38184046fb5d9674f12e88dd38552db256a
downloadaur-2858829787a1f632879d988a0692ad940e7f96bd.tar.gz
Still there are some issues to solve. The most important python-galsim E: Insecure RPATH
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD49
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b976c96d73a4
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-galsim
+ pkgdesc = The modular galaxy image simulation toolkit
+ pkgver = 1.5.0
+ pkgrel = 1
+ url = https://github.com/GalSim-developers/GalSim/releases/tag/v1.5.0-alpha
+ arch = x86_64
+ license = unknown
+ makedepends = git
+ depends = python
+ depends = scons
+ depends = fftw
+ depends = boost
+ depends = tmv
+ source = https://github.com/GalSim-developers/GalSim/archive/v1.5.0-alpha.tar.gz
+ md5sums = f74fd061510a1e507d6b9bc9f010e84c
+
+pkgname = python-galsim
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..22972d761ee0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+# This is an example PKGBUILD file. Use this as a start to creating your own,
+# and remove these comments. For more information, see 'man PKGBUILD'.
+# NOTE: Please fill out the license field for your package! If it is unknown,
+# then please put 'unknown'.
+
+# Maintainer: Andres Alejandro Navarro Alsina <aanavarroa@unal.edu.co>
+# Contributor: GalSim developers team on GitHub
+pkgname=python-galsim
+pkgver=1.5.0
+pkgrel=1
+#epoch=
+
+pkgdesc=" The modular galaxy image simulation toolkit "
+
+
+arch=('x86_64')
+url="https://github.com/GalSim-developers/GalSim/releases/tag/v1.5.0-alpha"
+license=('unknown')
+groups=()
+depends=('python' 'scons' 'fftw' 'boost' 'tmv')
+makedepends=('git')
+checkdepends=()
+optdepends=()
+#provides=()
+#conflicts=()
+#replaces=()
+#backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/GalSim-developers/GalSim/archive/v1.5.0-alpha.tar.gz")
+#noextract=()
+md5sums=('f74fd061510a1e507d6b9bc9f010e84c')
+#validpgpkeys=()
+
+
+build() {
+ cd "$src"
+ cd "GalSim-$pkgver-alpha"
+ scons PREFIX=/usr TMV_DIR=/usr
+}
+
+
+package() {
+ cd "$src"
+ cd "GalSim-$pkgver-alpha"
+ scons PREFIX=$pkgdir/usr install
+
+}