summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-02-02 14:29:47 +0800
committerUniversebenzene2020-02-02 14:29:47 +0800
commita2a03003ae1a165ac74900aa695bc6c3cbc58130 (patch)
tree140638eac89b39259e114502ae2437fa3eb68201
parent6dc43306f92301691e43ba1f57cbe729b2f080bf (diff)
downloadaur-a2a03003ae1a165ac74900aa695bc6c3cbc58130.tar.gz
Update to version 0.16
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD8
3 files changed, 7 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f67c429b455f..48063c8839f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-gammapy
pkgdesc = A Python package for gamma-ray astronomy
- pkgver = 0.15
+ pkgver = 0.16
pkgrel = 1
url = https://gammapy.org/
arch = i686
@@ -19,8 +19,8 @@ pkgbase = python-gammapy
checkdepends = python-pydantic
makedepends = cython
makedepends = python-numpy
- source = https://files.pythonhosted.org/packages/source/g/gammapy/gammapy-0.15.tar.gz
- md5sums = 49b0ef74115dc9e345b1f95e96b390d9
+ source = https://files.pythonhosted.org/packages/source/g/gammapy/gammapy-0.16.tar.gz
+ md5sums = d2838c432053c772095ae9a71bce65f2
pkgname = python-gammapy
depends = python>=3.6
@@ -29,10 +29,8 @@ pkgname = python-gammapy
depends = python-regions>=0.4
depends = python-click>=7.0
depends = python-pydantic>=1.0
- optdepends = python-reproject: For image reprojection
optdepends = python-iminuit: For fitting by optimization
optdepends = python-pandas: For working with tables
- optdepends = python-uncertainties: For linear error propagation
optdepends = python-matplotlib: For plotting
optdepends = python-emcee: For fitting by MCMC sampling
optdepends = python-corner: For MCMC corner plots
diff --git a/.gitignore b/.gitignore
index 0d6e3b36c63a..e896dcd6056d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -4,5 +4,5 @@ pkg
*.tar.gz
*.tar.bz2
*.part
-*.pkg.tar.xz
+*.pkg.tar.*
*.log
diff --git a/PKGBUILD b/PKGBUILD
index 419d0d274b7a..56f7d5247001 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-gammapy
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=0.15
+pkgver=0.16
pkgrel=1
pkgdesc="A Python package for gamma-ray astronomy"
arch=('i686' 'x86_64')
@@ -23,7 +23,7 @@ checkdepends=('python-pytest'
'python-click'
'python-pydantic')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('49b0ef74115dc9e345b1f95e96b390d9')
+md5sums=('d2838c432053c772095ae9a71bce65f2')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -42,10 +42,8 @@ check() {
package_python-gammapy() {
depends=('python>=3.6' 'python-yaml>=5.1' 'python-astropy>=3.2' 'python-regions>=0.4' 'python-click>=7.0' 'python-pydantic>=1.0')
- optdepends=('python-reproject: For image reprojection'
- 'python-iminuit: For fitting by optimization'
+ optdepends=('python-iminuit: For fitting by optimization'
'python-pandas: For working with tables'
- 'python-uncertainties: For linear error propagation'
'python-matplotlib: For plotting'
'python-emcee: For fitting by MCMC sampling'
'python-corner: For MCMC corner plots'