summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-07-02 17:55:24 +0800
committerUniversebenzene2023-07-02 17:55:24 +0800
commitee3341d3c172afda90c38acd827a117e0355e23b (patch)
tree1a933f7e7dff21c4ec4b4084c2c5f09b27c348ff
parent4df8fe84cfdd83d461deab1bfa013761c3f8d246 (diff)
downloadaur-ee3341d3c172afda90c38acd827a117e0355e23b.tar.gz
Update to version 1.1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index be4d8e4510f2..40c18a679a44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = python-gammapy
pkgdesc = A Python package for gamma-ray astronomy
- pkgver = 1.0.1
+ pkgver = 1.1
pkgrel = 1
url = https://gammapy.org
arch = i686
arch = x86_64
license = BSD
checkdepends = python-pytest-astropy-header
- checkdepends = python-pytest-remotedata
checkdepends = python-scipy
checkdepends = python-regions
checkdepends = python-click
@@ -20,13 +19,13 @@ pkgbase = python-gammapy
makedepends = python-installer
makedepends = python-extension-helpers
makedepends = python-numpy
- source = https://files.pythonhosted.org/packages/source/g/gammapy/gammapy-1.0.1.tar.gz
- md5sums = 4294a87c34a161d4021c7bb7d11bf6f5
+ source = https://files.pythonhosted.org/packages/source/g/gammapy/gammapy-1.1.tar.gz
+ md5sums = 59386ea8a1677a023d9d6a4a306dc35b
pkgname = python-gammapy
depends = python>=3.8
depends = python-scipy>1.10
- depends = python-yaml>=5.1
+ depends = python-yaml>=5.3
depends = python-astropy>=5.0
depends = python-regions>=0.5.0
depends = python-click>=7.0
diff --git a/PKGBUILD b/PKGBUILD
index 74d9c9c072b5..c89ccced1e69 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=python-gammapy
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
#"python-${_pyname}-doc")
-pkgver=1.0.1
+pkgver=1.1
pkgrel=1
pkgdesc="A Python package for gamma-ray astronomy"
arch=('i686' 'x86_64')
@@ -23,7 +23,7 @@ makedepends=('cython'
# 'python-scipy'
# 'python-regions')
checkdepends=('python-pytest-astropy-header'
- 'python-pytest-remotedata'
+# 'python-pytest-remotedata'
'python-scipy'
'python-regions'
'python-click'
@@ -37,7 +37,7 @@ checkdepends=('python-pytest-astropy-header'
# 'jupyter-nbformat'
# 'python-sphinx'
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-md5sums=('4294a87c34a161d4021c7bb7d11bf6f5')
+md5sums=('59386ea8a1677a023d9d6a4a306dc35b')
get_pyver() {
python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
@@ -62,12 +62,13 @@ check() {
ln -rs ${srcdir}/${_pyname}-${pkgver}/${_pyname}*egg-info \
build/lib.linux-${CARCH}-cpython-$(get_pyver)/${_pyname}-${pkgver}-py$(get_pyver .).egg-info
-# PYTHONPATH="build/lib.linux-${CARCH}-cpython $(get_pyver)" pytest "build/lib.linux-${CARCH}-cpython-$(get_pyver)" || warning "Tests failed"
- pytest "build/lib.linux-${CARCH}-cpython-$(get_pyver)" || warning "Tests failed" # -vv --color=yes
+ PYTHONPATH="build/lib.linux-${CARCH}-cpython-$(get_pyver)" pytest "build/lib.linux-${CARCH}-cpython-$(get_pyver)" || warning "Tests failed" # -vv --color=yes
+# PYTHONPATH="build/lib.linux-${CARCH}-cpython-$(get_pyver)" pytest -vv --color=yes
+# pytest "build/lib.linux-${CARCH}-cpython-$(get_pyver)" #|| warning "Tests failed" # -vv --color=yes
}
package_python-gammapy() {
- depends=('python>=3.8' 'python-scipy>1.10' 'python-yaml>=5.1' 'python-astropy>=5.0' 'python-regions>=0.5.0' 'python-click>=7.0' 'python-pydantic>=1.4' 'python-iminuit>=2.8.0' 'python-matplotlib>=3.4')
+ depends=('python>=3.8' 'python-scipy>1.10' 'python-yaml>=5.3' 'python-astropy>=5.0' 'python-regions>=0.5.0' 'python-click>=7.0' 'python-pydantic>=1.4' 'python-iminuit>=2.8.0' 'python-matplotlib>=3.4')
optdepends=('python-pandas: For working with tables'
'python-emcee: For fitting by MCMC sampling'
'python-corner: For MCMC corner plots'