summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPadraic Fanning2023-08-15 20:24:01 -0400
committerPadraic Fanning2023-08-15 20:24:01 -0400
commit07841d9623702a8b8db2681c71302dd1c7166625 (patch)
tree34b38f8c1658f0172be4408ecb93066343fab937
parentb1204682d78a477bd2f39ff7e74ca710228a763c (diff)
downloadaur-07841d9623702a8b8db2681c71302dd1c7166625.tar.gz
Make this build/test successfully in a chroot
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 246169c24a43..7c8cb56a5e9a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -44,9 +44,12 @@ check() {
# xvfb-run --auto-servernum python -m pytest tests/
# export PYTHONPATH=$PYTHONPATH:.
# pytest
+ export TEST_GTK_VERSION='4.0'
local python_version=$(python -c 'import sys; print("".join(map(str, sys.version_info[:2])))')
echo "$python_version"
- python -m pytest -s tests
+ # NOTE: this command will segfault because test_guide.py can't run headless
+# python -m pytest -s tests
+ xvfb-run --auto-servernum python -m pytest -s tests
}
package() {