summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPadraic Fanning2022-04-03 14:24:35 -0400
committerPadraic Fanning2022-04-03 14:24:35 -0400
commitbba9629934c4cabe0bb1756eb42001b9d2218e79 (patch)
tree625b310024348afd732f38048f38c971b8b017d2
parentfa0b31e21db15a5e5eae936ad42fc6a33336909a (diff)
downloadaur-bba9629934c4cabe0bb1756eb42001b9d2218e79.tar.gz
Use virtual framebuffer for GUI test
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7628984e19f7..f6214b83a88f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = python-gaphas-git
pkgdesc = Diagramming widget library for Python
- pkgver = 3.5.0.r0.ga51f017
+ pkgver = 3.6.0.r3.gf012089
pkgrel = 1
url = https://github.com/gaphor/gaphas
arch = x86_64
arch = i686
license = Apache
checkdepends = python-pytest
+ checkdepends = xorg-server-xvfb
makedepends = git
makedepends = python-build
makedepends = python-installer
diff --git a/PKGBUILD b/PKGBUILD
index 3385c5834177..1175da865328 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: Yauhen Kirylau <actionless DOT loveless PLUS aur AT gmail MF com>
-# Contributor: Padraic Fanning <fanninpm AT miamioh DOT edu>
+# Maintainer: Padraic Fanning <fanninpm AT miamioh DOT edu>
_pkgname=python-gaphas
pkgname="${_pkgname}-git"
@@ -26,7 +26,10 @@ makedepends=(
)
optdepends=(
)
-checkdepends=('python-pytest')
+checkdepends=(
+ 'python-pytest'
+ 'xorg-server-xvfb'
+)
provides=(
"${_pkgname}"
)
@@ -44,7 +47,7 @@ build() {
check() {
cd "${srcdir}/${_pkgname}"
- pytest
+ xvfb-run --auto-servernum pytest
}
pkgver() {