summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoractionless2024-02-18 02:54:26 +0100
committeractionless2024-02-18 02:54:26 +0100
commit1a26b1053f9c868f01985daa1effdf7a539c7e69 (patch)
tree4e32930408b7bec6f480430693c567c7d980e68b
parentcf0f04b952faf875e947823397dfc47281538494 (diff)
downloadaur-python-gaphor.tar.gz
fix test command to not open million of random windows during the check() func
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
2 files changed, 3 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 43fc5e7ef965..e2060bcf5357 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-gaphor
pkgdesc = Simple and easy to use modeling tool for UML using GTK3
pkgver = 2.24.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/gaphor/gaphor
arch = any
license = Apache
diff --git a/PKGBUILD b/PKGBUILD
index c339b6676ed7..91f9b9577b47 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_name=gaphor
pkgname=python-${_name}
pkgver=2.24.0
-pkgrel=1
+pkgrel=2
pkgdesc="Simple and easy to use modeling tool for UML using GTK3"
arch=('any')
url="https://github.com/gaphor/${_name}"
@@ -54,7 +54,7 @@ build() {
check() {
cd "${srcdir}/${_name}-${pkgver}"
- python -m pytest -s tests
+ xvfb-run python -m pytest -s tests
}
prepare() {