summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntony Lee2016-02-04 23:31:52 -0800
committerAntony Lee2016-02-04 23:31:52 -0800
commit9019206fd1a3b1913a59700a168dd57f5c1be34a (patch)
treeff26cc82f30c35812cd10e4b159044d8024f91f1
downloadaur-9019206fd1a3b1913a59700a168dd57f5c1be34a.tar.gz
Initial commit.
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..05a8276f607e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Fri Feb 5 07:30:57 UTC 2016
+pkgbase = python-gatspy
+ pkgdesc = General tools for Astronomical Time Series in Python
+ pkgver = 0.2.1
+ pkgrel = 1
+ url = http://www.astroml.org/gatspy/
+ arch = any
+ license = BSD
+ depends = python-scipy
+ optdepends = python-astroml
+ optdepends = python-supersmoother
+ source = https://pypi.python.org/packages/source/g/gatspy/gatspy-0.2.1.tar.gz
+ md5sums = 6321eba2ff5a95835d4ceae22c25b077
+
+pkgname = python-gatspy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6fc06b05ad38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Antony Lee <anntzer dot lee at gmail dot com>
+
+_pyname=gatspy
+pkgname=python-$_pyname
+pkgver=0.2.1
+pkgrel=1
+pkgdesc='General tools for Astronomical Time Series in Python'
+url='http://www.astroml.org/gatspy/'
+depends=('python-scipy')
+optdepends=('python-astroml' 'python-supersmoother')
+license=('BSD')
+arch=('any')
+source=("https://pypi.python.org/packages/source/${_pyname:0:1}/$_pyname/$_pyname-$pkgver.tar.gz")
+md5sums=('6321eba2ff5a95835d4ceae22c25b077')
+
+build() {
+ cd $srcdir/$_pyname-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/$_pyname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}