summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2021-04-16 17:28:50 -0400
committerGI_Jack2021-04-16 17:28:50 -0400
commit6a1bf39f54c17fd07f45e52318af2171e9288098 (patch)
treef9d903ce05fc5148ff9da3861b5ac50bc79f2767
downloadaur-6a1bf39f54c17fd07f45e52318af2171e9288098.tar.gz
initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9f5efe52b536
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo(replacement shim) v8
+# Fri Apr 16 05:28:44 PM EDT 2021
+pkgbase = python-gatt
+ pkgdesc = Bluetooth GATT SDK for Python helps you implementing and communicating with any Bluetooth Low Energy device that has a GATT profile
+ pkgver = 0.2.7
+ pkgrel = 1
+ url = https://github.com/getsenic/gatt-python
+ arch = any
+ license = GPLv3
+ makedepends = python-setuptools
+ depends = python
+ depends = bluez
+ source = https://files.pythonhosted.org/packages/source/g/gatt/gatt-0.2.7.tar.gz
+ sha256sums = 626d9de24a178b6eaff78c31b0bd29f962681da7caf18eb20363f6288d014e3a
+
+pkgname = python-gatt
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5337039f0106
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: GI_Jack <GI_Jack@hackermail.com>
+
+pkgname=python-gatt
+_pkgname=gatt
+pkgver=0.2.7
+pkgrel=1
+pkgdesc="Bluetooth GATT SDK for Python helps you implementing and communicating with any Bluetooth Low Energy device that has a GATT profile"
+url="https://github.com/getsenic/gatt-python"
+arch=('any')
+license=('GPLv3')
+depends=('python' 'bluez')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
+sha256sums=('626d9de24a178b6eaff78c31b0bd29f962681da7caf18eb20363f6288d014e3a')
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+}