summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGI_Jack2023-05-13 20:04:22 -0700
committerGI_Jack2023-05-13 20:04:22 -0700
commit823399b8954f030bbb4536e2209a1aeac5938d1f (patch)
tree3d0964d29294ac625b94e1a01ae5d8169102b3fc
parenta132ee8137e4163cd28668be94897d1cdac07fa6 (diff)
downloadaur-823399b8954f030bbb4536e2209a1aeac5938d1f.tar.gz
updated for modern packaging guidelines
-rw-r--r--PKGBUILD13
1 files changed, 9 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 4490316c44fc..8286e05a38a8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,17 +3,22 @@
pkgname=python-gatt
_pkgname=gatt
pkgver=0.2.7
-pkgrel=2
+pkgrel=3
pkgdesc="Bluetooth GATT SDK for Python helps you implementing and communicating with any Bluetooth Low Energy device that has a GATT profile"
url="https://github.com/getsenic/gatt-python"
arch=('any')
license=('MIT')
depends=('python' 'bluez' 'python-gobject')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz")
sha256sums=('626d9de24a178b6eaff78c31b0bd29f962681da7caf18eb20363f6288d014e3a')
+build() {
+ cd "${_pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
+}
+
package() {
- cd ${_pkgname}-${pkgver}
- python setup.py install -O1 --root="${pkgdir}" --prefix=/usr
+ cd "${_pkgname}-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
}