summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2023-07-07 23:44:21 +0800
committerUniversebenzene2023-07-07 23:44:21 +0800
commitde733dafb7c270150507eae08184fdd0bfa33eb2 (patch)
tree2670b4f85dc982d0e260bdb7ef366964895d8d3a
parent54f23d58de6abaf0d8de981aa2ef5827a32598e0 (diff)
downloadaur-de733dafb7c270150507eae08184fdd0bfa33eb2.tar.gz
Update to version 1.0.2
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
2 files changed, 26 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7f52805abb83..2194d38246e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,21 @@
pkgbase = python-gdl
pkgdesc = Python interface for the GNU Data Language(GDL)
- pkgver = 1.0.0
+ pkgver = 1.0.2
pkgrel = 1
url = http://gnudatalanguage.sourceforge.net
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
- depends = gnudatalanguage=1.0.0
+ makedepends = eigen
+ depends = gnudatalanguage=1.0.2
+ depends = python-numpy
conflicts = python2-gdl
- source = https://github.com/gnudatalanguage/gdl/archive/v1.0.0.tar.gz
+ source = https://github.com/gnudatalanguage/gdl/archive/v1.0.2.tar.gz
source = gdl.profile
- md5sums = 08fd60b29a487445dea719790d51eb48
+ source = gdl-1.0.1-fix-python-wxGetApp.patch
+ md5sums = 0a86735911637bcdb6935ee6cd14d751
md5sums = 40aa5fd8278cd8e80425c62a577563cc
+ md5sums = bf1e1fb364eaf92e09ad7031c0c2b546
pkgname = python-gdl
diff --git a/PKGBUILD b/PKGBUILD
index ee01477cbbfe..20fd7cfd7224 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,25 +5,32 @@
# Contributor: Jan Kohnert <kohni.jk at gmail dot com>
pkgname=python-gdl
-pkgver=1.0.0
+pkgver=1.0.2
pkgrel=1
pkgdesc="Python interface for the GNU Data Language(GDL)"
arch=('i686' 'x86_64')
url="http://gnudatalanguage.sourceforge.net"
license=('GPL')
-depends=("gnudatalanguage=${pkgver}")
-makedepends=('cmake')
+depends=("gnudatalanguage=${pkgver}" 'python-numpy')
+makedepends=('cmake' 'eigen')
#options=('!makeflags')
conflicts=('python2-gdl')
source=("https://github.com/gnudatalanguage/gdl/archive/v${pkgver}.tar.gz"
- 'gdl.profile')
-md5sums=('08fd60b29a487445dea719790d51eb48'
- '40aa5fd8278cd8e80425c62a577563cc')
+ 'gdl.profile'
+ 'gdl-1.0.1-fix-python-wxGetApp.patch')
+md5sums=('0a86735911637bcdb6935ee6cd14d751'
+ '40aa5fd8278cd8e80425c62a577563cc'
+ 'bf1e1fb364eaf92e09ad7031c0c2b546')
+
+get_pyinfo() {
+ [[ $1 == "site" ]] && python -c "import site; print(site.getsitepackages()[0])" || \
+ python -c "import sys; print('$1'.join(map(str, sys.version_info[:2])))"
+}
prepare() {
cd ${srcdir}/gdl-${pkgver}
- export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
+ patch -Np1 -i "${srcdir}/gdl-1.0.1-fix-python-wxGetApp.patch"
}
build() {
@@ -35,23 +42,22 @@ build() {
cd build
cmake -Wno-dev -DCMAKE_INSTALL_PREFIX=/usr -DEIGEN3=ON -DFFTW=ON -DGLPK=ON \
-DGRAPHICSMAGICK=ON -DGRIB=ON -DHDF5=ON -DHDF=ON -DHDFDIR=/opt/hdf4 \
- -DLIBPROJ=ON -DMAGICK=OFF -DMPI=ON -DNETCDF=ON \
- -DPYTHON_MODULE=ON -DREADLINE=ON -DSHAPELIB=ON -DUDUNITS2=ON \
- -DPYTHON=ON -DPYTHONVERSION=3 ..
+ -DLIBPROJ=ON -DMAGICK=OFF -DMPI=ON -DNETCDF=ON -DPYTHON=ON \
+ -DPYTHONVERSION=3 -DPYTHON_MODULE=ON -DQHULL=OFF -DREADLINE=ON \
+ -DSHAPELIB=ON -DUDUNITS2=ON ..
make
}
package() {
cd ${srcdir}/gdl-${pkgver}/build
- export _pyver=$(python -c 'import sys; print("%d.%d" % sys.version_info[:2])')
if [[ -d ../pkginstall ]]; then
rm -r ../pkginstall
fi
mkdir ../pkginstall
make DESTDIR=../pkginstall install
- install -D -m755 -t "${pkgdir}/usr/lib/python${_pyver}/site-packages" ../pkginstall/usr/lib/python"${_pyver}"/site-packages/GDL.so
+ install -D -m755 -t "${pkgdir}/$(get_pyinfo site)" ../pkginstall/$(get_pyinfo site)/GDL.so
install -m755 -t "${pkgdir}/usr/lib" ../pkginstall/usr/lib/libantlr.so
install -D -m644 -t "${pkgdir}/usr/share/doc/gnudatalanguage" ../PYTHON.txt
}