summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Heitzmann Gabrielli2015-06-25 21:14:32 -0300
committerLucas Heitzmann Gabrielli2015-06-25 21:14:32 -0300
commit116521e906ee2e383605ec64fc1084e719158594 (patch)
tree03e7ff24d2afda6e4e71f7ca0367e59fff8edcca
downloadaur-116521e906ee2e383605ec64fc1084e719158594.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD29
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6b4bc7aa20e8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-gdspy
+ pkgdesc = Gdspy is a Python module for creating GDSII stream files, usually CAD layouts.
+ pkgver = 0.7
+ pkgrel = 1
+ url = http://gdspy.sourceforge.net/
+ arch = x86_64
+ arch = i686
+ license = GPL3
+ depends = python
+ depends = python-numpy
+ source = http://downloads.sourceforge.net/project/gdspy/gdspy/gdspy-0.7/gdspy-0.7.zip
+ md5sums = 8f69f47a27476e0f099f241d6bb12143
+
+pkgname = python-gdspy
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c47fc692e052
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+gdspy-*.zip
+python-gdspy-*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e7f5286b745f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Lucas H. Gabrielli <heitzmann@gmail.com>
+modname=gdspy
+pkgname=python-${modname}
+pkgver=0.7
+pkgrel=1
+pkgdesc="Gdspy is a Python module for creating GDSII stream files, usually CAD layouts."
+url="http://gdspy.sourceforge.net/"
+arch=('x86_64' 'i686')
+license=('GPL3')
+depends=('python' 'python-numpy')
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+install=
+source=("http://downloads.sourceforge.net/project/${modname}/${modname}/${modname}-${pkgver}/${modname}-${pkgver}.zip")
+md5sums=('8f69f47a27476e0f099f241d6bb12143')
+
+build() {
+ cd "${srcdir}/${modname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${modname}-${pkgver}"
+ python setup.py install --root=${pkgdir}
+}
+
+# vim:set ts=2 sw=2 et: