summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStanda Lukeš2024-05-07 15:54:48 +0200
committerStanda Lukeš2024-05-07 15:54:48 +0200
commit6be8e5a6aa86e2140927232fd44ae5c837139377 (patch)
tree45bc2ceed545cbeb878f11144cfc00d562bba204
downloadaur-6be8e5a6aa86e2140927232fd44ae5c837139377.tar.gz
Initial commit
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..618aa9beed0e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = python-gemmi
+ pkgdesc = macromolecular crystallography library (Python bindings)
+ pkgver = 0.6.5
+ pkgrel = 1
+ url = https://gemmi.readthedocs.io/
+ arch = x86_64
+ license = MPL-2.0
+ makedepends = cmake
+ makedepends = pybind11
+ makedepends = python-pybind11-stubgen
+ makedepends = python-scikit-build-core
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python
+ depends = python-numpy
+ source = https://github.com/project-gemmi/gemmi/archive/refs/tags/v0.6.5.tar.gz
+ sha256sums = 9159506a16e0d22bbeeefc4d34137099318307db1b2bebf06fb2ae501571b19c
+
+pkgname = python-gemmi
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2b5212935d8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Standa Lukeš <archpkg@exyi.cz>
+_pyname="gemmi"
+pkgname="python-${_pyname}"
+pkgver=0.6.5
+pkgrel=1
+pkgdesc="macromolecular crystallography library (Python bindings)"
+arch=(x86_64)
+url="https://gemmi.readthedocs.io/"
+license=('MPL-2.0')
+makedepends=(cmake pybind11 python-pybind11-stubgen python-scikit-build-core python-build python-installer python-wheel)
+depends=(python python-numpy)
+checkdepends=()
+source=("https://github.com/project-gemmi/${_pyname}/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('9159506a16e0d22bbeeefc4d34137099318307db1b2bebf06fb2ae501571b19c')
+
+build() {
+ cd "${_pyname}-${pkgver}"
+ # from gemmi/pyproject.toml, but they set it only for their CI
+ export SKBUILD_CMAKE_ARGS='-DBUILD_GEMMI_PROGRAM=OFF;-DINSTALL_DEV_FILES=OFF;-DBUILD_SHARED_LIBS=OFF;-DFETCH_ZLIB_NG=ON'
+ python -m build --wheel --no-isolation --skip-dependency-check
+ # it is too sensitive about exact versions ^^^^^^^^^^^^^^^^^^^
+}
+
+package() {
+ cd "${_pyname}-${pkgver}"
+ python -m installer --destdir="${pkgdir}" dist/*.whl
+}