summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPumpkinCheshire2020-12-30 09:18:00 +0800
committerPumpkinCheshire2020-12-30 09:18:00 +0800
commit9f7a3c3d603a78da2d3f63c5122e47751f625513 (patch)
tree3ba1e71839d208f436371e7cf91594da84b7be19
parent777690ef54c978b91e2648dbd437bb14b892e146 (diff)
downloadaur-9f7a3c3d603a78da2d3f63c5122e47751f625513.tar.gz
bump to 0.3.0
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore19
-rw-r--r--PKGBUILD14
3 files changed, 19 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f82c5b7f4e6c..b56e7625246c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python-geomet
pkgdesc = GeoMet - Convert GeoJSON to WKT/WKB, and vice versa.
- pkgver = 0.2.1.post1
- pkgrel = 2
- url = https://pysal.org/libpysal
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/geomet/geomet
arch = any
license = Apache
makedepends = python-setuptools
@@ -11,8 +11,10 @@ pkgbase = python-geomet
optdepends = python-nose: tests
optdepends = python-coverage: tests
optdepends = flake8: tests
- source = https://files.pythonhosted.org/packages/source/g/geomet/geomet-0.2.1.post1.tar.gz
- sha256sums = 91d754f7c298cbfcabd3befdb69c641c27fe75e808b27aa55028605761d17e95
+ source = https://files.pythonhosted.org/packages/source/g/geomet/geomet-0.3.0.tar.gz
+ source = https://raw.githubusercontent.com/geomet/geomet/master/LICENSE
+ sha256sums = cb52411978ee01ff104ab48f108d7333b14423ae7a15a65fee25b7d29bda2e1b
+ sha256sums = cb5e8e7e5f4a3988e1063c142c60dc2df75605f4c46515e776e3aca6df976e14
pkgname = python-geomet
diff --git a/.gitignore b/.gitignore
index 96861d8a35c0..018a3de08144 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,15 +1,4 @@
-*.log
-*.rpm
-*.deb
-*.tar*
-*.gz
-*.zip
-*.run
-*.whl
-*.AppImage
-*.jar
-*.tgz
-*.pdf
-test*
-src/
-pkg/
+*
+!PKGBUILD
+!.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 9d5ef4f25841..58bb199148b8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,11 +2,11 @@
_name=geomet
pkgname=python-geomet
-pkgver=0.2.1.post1
-pkgrel=2
+pkgver=0.3.0
+pkgrel=1
pkgdesc="GeoMet - Convert GeoJSON to WKT/WKB, and vice versa."
arch=('any')
-url="https://pysal.org/libpysal"
+url="https://github.com/geomet/geomet"
license=('Apache')
depends=('python-click' 'python-six')
optdepends=(
@@ -15,8 +15,10 @@ optdepends=(
'flake8: tests'
)
makedepends=('python-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
-sha256sums=('91d754f7c298cbfcabd3befdb69c641c27fe75e808b27aa55028605761d17e95')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz"
+ "https://raw.githubusercontent.com/geomet/geomet/master/LICENSE")
+sha256sums=('cb52411978ee01ff104ab48f108d7333b14423ae7a15a65fee25b7d29bda2e1b'
+ 'cb5e8e7e5f4a3988e1063c142c60dc2df75605f4c46515e776e3aca6df976e14')
build() {
cd "$_name-$pkgver"
@@ -26,6 +28,6 @@ build() {
package() {
cd "$_name-$pkgver"
python setup.py install --root="$pkgdir" --optimize=1 --skip-build
- install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
# rm "$pkgdir/usr/LICENSE"
}