summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2020-08-13 14:06:31 -0400
committerGuillaume Horel2020-08-13 14:07:24 -0400
commit1135b2c3f807151ecace977e4972334b05310e64 (patch)
treecf17eaba4b5bb8adeaa1d14d8a165e34784215b1
parentb8de66a399b9532a7979afabf305a04574024fe4 (diff)
downloadaur-1135b2c3f807151ecace977e4972334b05310e64.tar.gz
version bump
-rw-r--r--.SRCINFO10
-rw-r--r--1544.patch76
-rw-r--r--PKGBUILD18
3 files changed, 95 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a0e4384cf63a..d7e0eb127f30 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-geopandas
pkgdesc = Geographic pandas extension
- pkgver = 0.7.0
+ pkgver = 0.8.1
pkgrel = 1
url = https://github.com/geopandas/geopandas
arch = any
@@ -15,13 +15,15 @@ pkgbase = python-geopandas
depends = python-pandas
depends = python-pyproj
depends = python-shapely
- depends = python-six
+ optdepends = python-pyarrow
optdepends = python-descartes
optdepends = python-geopy
optdepends = python-psycopg2
options = !emptydirs
- source = python-geopandas-0.7.0.tar.gz::https://github.com/geopandas/geopandas/archive/v0.7.0.tar.gz
- sha256sums = 7a59954a66b7ab6bf7ff84ee4bed712183286d54d2008a02b0b757ec248e0c75
+ source = python-geopandas-0.8.1.tar.gz::https://github.com/geopandas/geopandas/archive/v0.8.1.tar.gz
+ source = 1544.patch
+ sha256sums = c73b7c5a428ffa2c9b1fe8c0ff267d67df9a87143a0d3a95323401823218a7b1
+ sha256sums = cb7ce76526a311fbe5e47df8b79d90b8dec0eeeb2a736b6f3482acee68ffa4f1
pkgname = python-geopandas
diff --git a/1544.patch b/1544.patch
new file mode 100644
index 000000000000..ec9a66095155
--- /dev/null
+++ b/1544.patch
@@ -0,0 +1,76 @@
+From 15a8f2beecde7bea2e990f1d5aa0c262beac8ee4 Mon Sep 17 00:00:00 2001
+From: Martin Fleischmann <martin@martinfleischmann.net>
+Date: Tue, 28 Jul 2020 20:38:05 +0100
+Subject: [PATCH 1/3] BUG: fix version check for pandas 1.1.0
+
+---
+ geopandas/_compat.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/geopandas/_compat.py b/geopandas/_compat.py
+index bdf6176b0..907678bc5 100644
+--- a/geopandas/_compat.py
++++ b/geopandas/_compat.py
+@@ -12,7 +12,7 @@
+
+ PANDAS_GE_025 = str(pd.__version__) >= LooseVersion("0.25.0")
+ PANDAS_GE_10 = str(pd.__version__) >= LooseVersion("0.26.0.dev")
+-PANDAS_GE_11 = str(pd.__version__) >= LooseVersion("1.1.0.dev")
++PANDAS_GE_11 = str(pd.__version__) >= LooseVersion("1.1.0")
+
+
+ # -----------------------------------------------------------------------------
+
+From 6ce868a33a2f483b071089d51e178030fa4414d0 Mon Sep 17 00:00:00 2001
+From: Martin Fleischmann <martin@martinfleischmann.net>
+Date: Tue, 28 Jul 2020 20:40:02 +0100
+Subject: [PATCH 2/3] add ValueError
+
+---
+ geopandas/tests/test_pandas_methods.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/geopandas/tests/test_pandas_methods.py b/geopandas/tests/test_pandas_methods.py
+index d34fe8b12..68906e19d 100644
+--- a/geopandas/tests/test_pandas_methods.py
++++ b/geopandas/tests/test_pandas_methods.py
+@@ -279,7 +279,7 @@ def test_numerical_operations(s, df):
+ with pytest.raises(TypeError):
+ s.max()
+
+- with pytest.raises(TypeError):
++ with pytest.raises((TypeError, ValueError)):
+ s.idxmax()
+
+ # numerical ops raise an error
+
+From 177d97fb68a18644dbc001d8e8fb7ce8a71ccf92 Mon Sep 17 00:00:00 2001
+From: Martin Fleischmann <martin@martinfleischmann.net>
+Date: Fri, 31 Jul 2020 18:02:35 +0100
+Subject: [PATCH 3/3] comments
+
+---
+ geopandas/tests/test_pandas_methods.py | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/geopandas/tests/test_pandas_methods.py b/geopandas/tests/test_pandas_methods.py
+index 68906e19d..354a63739 100644
+--- a/geopandas/tests/test_pandas_methods.py
++++ b/geopandas/tests/test_pandas_methods.py
+@@ -272,7 +272,7 @@ def test_numerical_operations(s, df):
+ exp = pd.Series([3, 4], index=["value1", "value2"])
+ assert_series_equal(df.sum(), exp)
+
+- # series methods raise error
++ # series methods raise error (not supported for geometry)
+ with pytest.raises(TypeError):
+ s.sum()
+
+@@ -280,6 +280,7 @@ def test_numerical_operations(s, df):
+ s.max()
+
+ with pytest.raises((TypeError, ValueError)):
++ # TODO: remove ValueError after pandas-dev/pandas#32749
+ s.idxmax()
+
+ # numerical ops raise an error
diff --git a/PKGBUILD b/PKGBUILD
index 93855fa0f6e7..0be970df7aa8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,18 +1,25 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=python-geopandas
_pkgname=geopandas
-pkgver=0.7.0
+pkgver=0.8.1
pkgrel=1
pkgdesc="Geographic pandas extension"
arch=('any')
url="https://github.com/geopandas/geopandas"
license=('BSD')
checkdepends=('python-descartes' 'python-matplotlib' 'python-pytest' 'python-rtree')
-depends=('python' 'python-fiona' 'python-numpy' 'python-pandas' 'python-pyproj' 'python-shapely' 'python-six')
-optdepends=('python-descartes' 'python-geopy' 'python-psycopg2')
+depends=('python' 'python-fiona' 'python-numpy' 'python-pandas' 'python-pyproj' 'python-shapely')
+optdepends=('python-pyarrow' 'python-descartes' 'python-geopy' 'python-psycopg2')
options=(!emptydirs)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/geopandas/geopandas/archive/v$pkgver.tar.gz")
-sha256sums=('7a59954a66b7ab6bf7ff84ee4bed712183286d54d2008a02b0b757ec248e0c75')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/geopandas/geopandas/archive/v$pkgver.tar.gz"
+ "1544.patch")
+sha256sums=('c73b7c5a428ffa2c9b1fe8c0ff267d67df9a87143a0d3a95323401823218a7b1'
+ 'cb7ce76526a311fbe5e47df8b79d90b8dec0eeeb2a736b6f3482acee68ffa4f1')
+
+prepare() {
+ cd "$_pkgname-$pkgver"
+ patch -p1 < ../1544.patch
+}
check() {
cd "$srcdir/$_pkgname-$pkgver"
@@ -22,4 +29,5 @@ check() {
package() {
cd "$srcdir/$_pkgname-$pkgver"
python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}