summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGuillaume Horel2019-11-30 21:51:08 -0500
committerGuillaume Horel2019-11-30 21:51:08 -0500
commit329d372113895c6ab2ce424edd597d8f17499ca8 (patch)
treef868c086f746e00a4d24f5bd7a1c8246b980528e
parente910bcb107a76a46185a485ee270b2eb9c40a2fd (diff)
downloadaur-329d372113895c6ab2ce424edd597d8f17499ca8.tar.gz
version bump
-rw-r--r--.SRCINFO8
-rw-r--r--1227.patch56
-rw-r--r--PKGBUILD9
3 files changed, 67 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4d8000934b31..1adf865afb00 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-geopandas
pkgdesc = Geographic pandas extension
- pkgver = 0.6.1
+ pkgver = 0.6.2
pkgrel = 1
url = https://github.com/geopandas/geopandas
arch = any
@@ -20,8 +20,10 @@ pkgbase = python-geopandas
optdepends = python-geopy
optdepends = python-psycopg2
options = !emptydirs
- source = python-geopandas-0.6.1.tar.gz::https://github.com/geopandas/geopandas/archive/v0.6.1.tar.gz
- sha256sums = 97f47820e5df308d5a1586cbc942ec88c56078596942f03d5dc439b0b568f741
+ source = python-geopandas-0.6.2.tar.gz::https://github.com/geopandas/geopandas/archive/v0.6.2.tar.gz
+ source = 1227.patch
+ sha256sums = 2097f9661b8f04ce49592dcb523a861829c1bd6ad747454355c93cc341cd366b
+ sha256sums = 8236ac8a9f8d8f5b37485d59e81d400d0f7e42f624951fdd6df0599ed5397a47
pkgname = python-geopandas
diff --git a/1227.patch b/1227.patch
new file mode 100644
index 000000000000..2eea0531cf76
--- /dev/null
+++ b/1227.patch
@@ -0,0 +1,56 @@
+From 3bd2caa67fb61d154677706a18fa23be027a184d Mon Sep 17 00:00:00 2001
+From: Joris Van den Bossche <jorisvandenbossche@gmail.com>
+Date: Fri, 29 Nov 2019 11:07:56 +0100
+Subject: [PATCH] TST: fix tests to work with rtree 0.9
+
+---
+ geopandas/tests/test_sindex.py | 24 ++++++++++++++++++------
+ 1 file changed, 18 insertions(+), 6 deletions(-)
+
+diff --git a/geopandas/tests/test_sindex.py b/geopandas/tests/test_sindex.py
+index 71ab30ea..fe1ab422 100644
+--- a/geopandas/tests/test_sindex.py
++++ b/geopandas/tests/test_sindex.py
+@@ -1,3 +1,4 @@
++from distutils.version import LooseVersion
+ import sys
+
+ from shapely.geometry import Point, Polygon
+@@ -11,8 +12,16 @@
+ @pytest.mark.skipif(sys.platform.startswith("win"), reason="fails on AppVeyor")
+ @pytest.mark.skipif(not base.HAS_SINDEX, reason="Rtree absent, skipping")
+ class TestSeriesSindex:
+- def test_empty_index(self):
+- assert GeoSeries().sindex is None
++ def test_empty_geoseries(self):
++ import rtree
++
++ if LooseVersion(rtree.__version__) >= LooseVersion("0.9"):
++ # See https://github.com/Toblerity/rtree/issues/122
++ # rtree version 0.9 now creates an empty index instead of raising
++ # an error (which was captured when creating the sindex)
++ assert GeoSeries().sindex is not None
++ else:
++ assert GeoSeries().sindex is None
+
+ def test_point(self):
+ s = GeoSeries([Point(0, 0)])
+@@ -24,11 +33,14 @@ def test_point(self):
+
+ def test_empty_point(self):
+ s = GeoSeries([Point()])
+- assert s.sindex is None
+- assert s._sindex_generated is True
++ import rtree
+
+- def test_empty_geo_series(self):
+- assert GeoSeries().sindex is None
++ if LooseVersion(rtree.__version__) >= LooseVersion("0.9"):
++ # see above
++ assert s.sindex is not None
++ else:
++ assert s.sindex is None
++ assert s._sindex_generated is True
+
+ def test_polygons(self):
+ t1 = Polygon([(0, 0), (1, 0), (1, 1)])
diff --git a/PKGBUILD b/PKGBUILD
index b0d0dbfd3771..5cb188465d81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
pkgname=python-geopandas
_pkgname=geopandas
-pkgver=0.6.1
+pkgver=0.6.2
pkgrel=1
pkgdesc="Geographic pandas extension"
arch=('any')
@@ -11,11 +11,14 @@ checkdepends=('python-descartes' 'python-matplotlib' 'python-pytest' 'python-rtr
depends=('python' 'python-fiona' 'python-numpy' 'python-pandas' 'python-pyproj' 'python-shapely' 'python-six')
optdepends=('python-descartes' 'python-geopy' 'python-psycopg2')
options=(!emptydirs)
-source=("$pkgname-$pkgver.tar.gz::https://github.com/geopandas/geopandas/archive/v$pkgver.tar.gz")
-sha256sums=('97f47820e5df308d5a1586cbc942ec88c56078596942f03d5dc439b0b568f741')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/geopandas/geopandas/archive/v$pkgver.tar.gz"
+ "1227.patch")
+sha256sums=('2097f9661b8f04ce49592dcb523a861829c1bd6ad747454355c93cc341cd366b'
+ '8236ac8a9f8d8f5b37485d59e81d400d0f7e42f624951fdd6df0599ed5397a47')
prepare() {
cd "$srcdir/$_pkgname-$pkgver"
+ patch -p1 < ../1227.patch
}
check() {