summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDringsim2024-05-06 13:57:29 +0800
committerDringsim2024-05-06 13:57:29 +0800
commit0e1f0a0706b21c4c894d55c73a5db719c05d44f4 (patch)
tree77cb5ea64d8e757d01fc7b2e38822a708e385bef
parentfe1ced06665f482c32f93cb26bce88c8c978cb91 (diff)
downloadaur-python-geoplot.tar.gz
fix
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD12
2 files changed, 4 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 76dd06c630c0..3d05d78f6ae4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,29 +1,22 @@
pkgbase = python-geoplot
pkgdesc = High-level geospatial data visualization library for Python
pkgver = 0.5.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/ResidentMario/geoplot
arch = any
license = MIT
makedepends = python-build
makedepends = python-installer
+ makedepends = python-setuptools
makedepends = python-wheel
depends = python-matplotlib
depends = python-seaborn
depends = python-pandas
depends = python-geopandas
depends = python-cartopy
- depends = python-descartes
depends = python-mapclassify
depends = python-contextily
- optdepends = python-pytest
- optdepends = python-pytest-mpl
optdepends = python-scipy
- optdepends = python-pylint
- optdepends = python-sphinx
- optdepends = python-sphinx-gallery
- optdepends = python-sphinx_rtd_theme
- optdepends = python-mplleaflet
source = https://files.pythonhosted.org/packages/source/g/geoplot/geoplot-0.5.1.tar.gz
sha256sums = 9614b2caa193a42de943afa2fea953d0997b9daf25ab2949be0681361a122790
diff --git a/PKGBUILD b/PKGBUILD
index dd543ed75527..fd710991230a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,31 +5,23 @@
pkgname=python-geoplot
_name=geoplot
pkgver=0.5.1
-pkgrel=1
+pkgrel=2
pkgdesc='High-level geospatial data visualization library for Python'
url='https://github.com/ResidentMario/geoplot'
arch=('any')
license=('MIT')
-makedepends=('python-build' 'python-installer' 'python-wheel')
+makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
depends=(
'python-matplotlib'
'python-seaborn'
'python-pandas'
'python-geopandas'
'python-cartopy'
- 'python-descartes'
'python-mapclassify'
'python-contextily'
)
optdepends=(
- 'python-pytest'
- 'python-pytest-mpl'
'python-scipy'
- 'python-pylint'
- 'python-sphinx'
- 'python-sphinx-gallery'
- 'python-sphinx_rtd_theme'
- 'python-mplleaflet'
)
source=(
"https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"