summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjerry732042020-06-17 06:12:40 +0800
committerjerry732042020-06-17 06:12:40 +0800
commit6918857e5d48cdb6973bdee0b51cd75715a09f97 (patch)
tree33c4739eacc33d6a4988f2d7fd9a00e230e1dbcb
parenta901c34f5b26ff707e366d50e7128dc388a64caf (diff)
downloadaur-6918857e5d48cdb6973bdee0b51cd75715a09f97.tar.gz
Bump to 1.8.1-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD43
2 files changed, 27 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7b9ba77c99e0..7e617a71d726 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-geoviews
pkgdesc = Simple, concise geographical visualization in Python
- pkgver = 1.6.2
- pkgrel = 2
+ pkgver = 1.8.1
+ pkgrel = 1
url = https://github.com/pyviz/geoviews
arch = any
license = BSD
@@ -27,8 +27,8 @@ pkgbase = python-geoviews
optdepends = python-shapely
optdepends = python-xarray
optdepends = jupyter
- source = https://github.com/pyviz/geoviews/archive/v1.6.2.tar.gz
- sha256sums = b89c44168891fff3071e38a671a8f7806179a60733dbedc2a32143ebabc2b974
+ source = https://github.com/pyviz/geoviews/archive/v1.8.1.tar.gz
+ sha256sums = c71a3203a47dbff1e17af590c854bd2c44157f077b1d37589404e89238050b1f
pkgname = python-geoviews
diff --git a/PKGBUILD b/PKGBUILD
index 35732456a12c..f276edc738e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,41 @@
# Maintainer: jerry73204 <jerry73204 at google gmail>
pkgname='python-geoviews'
-pkgver=1.6.2
-pkgrel=2
+pkgver=1.8.1
+pkgrel=1
pkgdesc='Simple, concise geographical visualization in Python'
arch=('any')
url='https://github.com/pyviz/geoviews'
license=('BSD')
makedepends=('python-setuptools'
'python-param')
-depends=('python-bokeh'
- 'python-cartopy'
- 'python-holoviews'
- 'python-numpy'
- 'python-param')
-optdepends=('python-datashader'
- 'python-geopandas'
- 'python-netcdf4'
- 'python-gdal'
- 'python-matplotlib>2.2'
- 'python-pandas'
- 'python-pyct'
- 'python-scipy'
- 'python-shapely'
- 'python-xarray'
- 'jupyter')
+depends=(
+ 'python-bokeh'
+ 'python-cartopy'
+ 'python-holoviews'
+ 'python-numpy'
+ 'python-param'
+)
+optdepends=(
+ 'python-datashader'
+ 'python-geopandas'
+ 'python-netcdf4'
+ 'python-gdal'
+ 'python-matplotlib>2.2'
+ 'python-pandas'
+ 'python-pyct'
+ 'python-scipy'
+ 'python-shapely'
+ 'python-xarray'
+ 'jupyter'
+)
checkdepends=('python-pytest'
'python-coveralls'
'python-nose'
# 'python-nbsmoke' # This package is missing
'flake8')
source=("https://github.com/pyviz/geoviews/archive/v${pkgver}.tar.gz")
-sha256sums=('b89c44168891fff3071e38a671a8f7806179a60733dbedc2a32143ebabc2b974')
-
+sha256sums=('c71a3203a47dbff1e17af590c854bd2c44157f077b1d37589404e89238050b1f')
build() {
cd "${srcdir}/geoviews-${pkgver}"
python setup.py build