summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatthew Treinish2016-08-29 11:54:02 -0400
committerMatthew Treinish2016-08-29 11:54:02 -0400
commitba8ec36a3930d0abefc40c8024faf86fbdae40ea (patch)
tree403ba308bc138db0168352a16ecfbaece2783881
parent9f4634c5ab4f1ba74d2316098c9e4d1a3763f155 (diff)
downloadaur-ba8ec36a3930d0abefc40c8024faf86fbdae40ea.tar.gz
Update to 1.4.0 and include man page
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD13
2 files changed, 13 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5f8bc26eaba6..679498b2fbe4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = python2-gertty
pkgdesc = console-based interface to the Gerrit Code Review system
- pkgver = 1.3.2
- pkgrel = 2
+ pkgver = 1.4.0
+ pkgrel = 1
url = https://pypi.python.org/pypi/gertty
arch = any
license = Apache2
makedepends = python2
makedepends = python2-setuptools
+ makedepends = python2-sphinx
depends = python2-git
depends = python2-sqlalchemy
depends = python2-urwid
@@ -20,8 +21,8 @@ pkgbase = python2-gertty
depends = python2-pbr
depends = python2-six
conflicts = python2-gertty-git
- source = https://pypi.python.org/packages/source/g/gertty/gertty-1.3.2.tar.gz
- md5sums = 5f4a49840d63d445834b8ba9598ce9cd
+ source = https://pypi.python.org/packages/9e/ed/dd19a67c287fede452473a685ae3e30dba48a5b280173872450c73a4f94d/gertty-1.4.0.tar.gz
+ md5sums = 579416c212dd2bc089f3340d804da8d5
pkgname = python2-gertty
diff --git a/PKGBUILD b/PKGBUILD
index 8239cc58eba2..ac62f5424806 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,20 @@
pkgname=python2-gertty
-pkgver=1.3.2
-pkgrel=2
+pkgver=1.4.0
+pkgrel=1
pkgdesc="console-based interface to the Gerrit Code Review system"
arch=('any')
url='https://pypi.python.org/pypi/gertty'
license=('Apache2')
-source=("https://pypi.python.org/packages/source/g/gertty/gertty-$pkgver.tar.gz")
-md5sums=('5f4a49840d63d445834b8ba9598ce9cd')
-makedepends=('python2' 'python2-setuptools')
+source=("https://pypi.python.org/packages/9e/ed/dd19a67c287fede452473a685ae3e30dba48a5b280173872450c73a4f94d/gertty-1.4.0.tar.gz")
+md5sums=('579416c212dd2bc089f3340d804da8d5')
+makedepends=('python2' 'python2-setuptools' 'python2-sphinx')
depends=('python2-git' 'python2-sqlalchemy' 'python2-urwid' 'python2-dateutil' 'python2-requests' 'python2-ordereddict' 'python2-alembic' 'python2-yaml' 'python2-ply' 'python2-voluptuous' 'python2-pbr' 'python2-six')
conflicts=('python2-gertty-git')
package() {
cd $srcdir/gertty-$pkgver
python2 setup.py install --root=$pkgdir
+ sphinx-build2 -b man doc/source doc/build/man
+ gzip doc/build/man/gertty.1
+ install -D -m644 doc/build/man/gertty.1.gz $pkgdir/usr/share/man/man1/gertty.1.gz
}