summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2018-07-24 12:44:10 +0200
committerPhilipp A2018-07-24 12:44:10 +0200
commit82b44e55f8aa523c3502ad1ee7308b2393f6cb4e (patch)
tree2c674f9fa055ea89b5954358e93d83e574008683
downloadaur-82b44e55f8aa523c3502ad1ee7308b2393f6cb4e.tar.gz
initial
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a23ad8f6573f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-get_version
+ pkgdesc = Automatically use the latest “vX.X.X” tag as version in your Python package
+ pkgver = 2.0.1
+ pkgrel = 1
+ url = https://pypi.org/project/get_version
+ arch = any
+ license = GPL3
+ depends = python
+ depends = python-setuptools
+ noextract = get_version-2.0.1-py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py3/g/get_version/get_version-2.0.1-py3-none-any.whl
+ sha256sums = e918b5ae0a724d94f0356d498036fcb51b257848149b90b6f8b6c9358f79fcee
+
+pkgname = python-get_version
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..3dd78fea8ca9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pkg/
+/src/
+/*.whl
+/*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4c264c310cf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Philipp A. <flying-sheep@web.de>
+
+_name=get_version
+pkgname=python-$_name
+pkgver=2.0.1
+pkgrel=1
+pkgdesc='Automatically use the latest “vX.X.X” tag as version in your Python package'
+arch=('any')
+url="https://pypi.org/project/$_name"
+license=('GPL3')
+depends=(python python-setuptools)
+_wheel="$_name-$pkgver-py3-none-any.whl"
+source=("https://files.pythonhosted.org/packages/py3/${_name::1}/$_name/$_wheel")
+sha256sums=('e918b5ae0a724d94f0356d498036fcb51b257848149b90b6f8b6c9358f79fcee')
+noextract=("$_wheel")
+
+package() {
+ pip install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+}